Preface

CATIA - Assembly Design Version 5 workbench allows the design of assemblies with an intuitive and flexible user interface.

As a scalable workbench, CATIA - Assembly Design Version 5 can be cooperatively used with other current companion products such as CATIA - Part Design Version 5 and CATIA - Generative Drafting Version 5. The widest application portfolio in the industry is also accessible through interoperability with CATIA Solutions Version 4 to enable support of the full product development process from initial concept to product in operation. Digital Mock-Up (DMU) Navigator Version 5 inspection capabilities can also be used to review and check your assemblies. Interactive, variable-speed techniques such as walk-through and fly as well as other viewing tools let you visually navigate through large assemblies. For more information, see the CATIA - Infrastructure and CATIA - V4 Integration User's Guides.

The CATIA - Assembly Design User's Guide has been designed to show you how to create an assembly starting from scratch. This book aims at illustrating the several stages of creation you may encounter.

The information contained in the CATIA - Assembly Design User's Guide is specific to Version 5 Release 3 of the CATIA - Assembly Design workbench, which operates in a WINDOWS or UNIX workstation environment under the AIX, IRIX, SUN OS and HP-UX operating system.
Preferred Road Maps

This book is intended for the user who needs to become quickly familiar with the CATIA - Assembly Design Version 5 workbench. The user should be familiar with basic CATIA Version 5 concepts such as document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-step tutorial Getting Started. This tutorial will show you how to create an assembly.

For users who already know how to use the CATIA - Assembly Design workbench, we recommend you read the Advanced User Tasks.
Where to Find More Information

Prior to reading this book, we recommend that you read *CATIA- Infrastructure User's Guide Version 5*.

What's New?

New Task: Inserting CATPart or CATProduct Documents from a catalog
New Task: Defining a Multi-Instantiation
New Task: Fast Multi-Instantiation
New Task: Using a Pattern
New Task: Setting a Warning Message
New Task: Analyzing Dependencies
Enhanced: Additional Elements Available for Creating Contact Constraints
Enhanced: Fix Together
Enhanced: Bill of Material
Enhanced: Editing a Part in Assembly Design Context
Enhanced: Modifying the Properties of a Constraint
Enhanced: Modifying Component Properties
Getting Started

Before we discuss the detailed instructions for using the Assembly workbench, the following scenario aims at giving you a feel for what you can do with an Assembly document. You just need to follow the instructions as you progress.

The Getting Started section is composed of the following tasks:

- Entering the Workbench
- Fixing a Component
- Inserting an Existing Component
- Setting Constraints
- Moving
- Adding and Renaming a New Component
- Designing a Part
- Editing a Parameter
- Replacing a Component
- Analyzing Constraints
- Reconnecting Constraints
- Detecting Clashes
- Editing and Modifying a Component
- Bill of Material
- Exploding the Assembly
This scenario should take about 15 minutes to complete.

Eventually, the assembly will look like this:
Entering the Assembly Design Workbench and Opening Product1

This first task shows you how to enter the Assembly Design workbench and how to open an existing product.

1. Select the Start -> Mechanical Design -> Assembly Design command to launch the required workbench.

The Assembly Design workbench is opened. The commands for assembling parts are available in the toolbar to the right of the application window. You will notice that “Product1” is displayed in the specification tree, indicating the building block of the assembly to be created.

To know how to use the commands available in the Standard and View toolbars located in the application window border, please refer to CATIA- Infrastructure User's Guide Version 5.
2. Before following the scenario, make sure the option Work with the cache system is deactivated: use the Tools -> Options command, click Product to the left of the dialog box that appears, then click the Cache Management tab and uncheck the option Work with the cache system. For more information, refer to Using the Cache Memory.

3. Now, click the File -> Open command to open the documents we need.

4. In the File Selection dialog box that appears, open GettingStarted.CATProduct from the samples/assembly_design directory.

You will start the scenario with an existing assembly. Product1 is composed of three parts created in the Part Design Workbench:

1. CRIC_FRAME (in turquoise)
2. CRIC_BRANCH_3 (in blue)
3. CRIC_BRANCH_1 (in red)

From now on, these parts will be referred to as 'components'.

5. Surface and Coincidence constraints have been defined for these parts in the Assembly workbench. Click the + sign to the left of the Constraints text in the tree and apply the show mode on these constraints if you wish to view them in the geometry area.
Fixing a Component

This task shows you how to set the first constraint. It consists in fixing a component. This operation is to be done before moving the assembly, as shown later on.

1. Select CRIC_FRAME in the specification tree or in the geometry area.

2. Click the Fix command.

The component is immediately fixed.

The application indicates this by displaying a green anchor symbol on the component. Note also that the Constraints branch now displays the new constraint,
Inserting an Existing Component

This task shows you how to insert an existing component into the assembly.

1. Select Product1 in the specification tree.

2. Select Insert -> Existing Component... (or use the Existing Component contextual command).

3. In the dialog box that displays, select Sub_Product1.CATProduct and click Open.

A new component is added to the specification tree.

The assembly now includes four components: three parts and a sub-assembly.

This is the component you have just imported:
Setting Constraints Between Components

This task consists in setting a coincidence constraint, then a contact constraint between the component you have just inserted (Sub_Product1 and CRIC_BRANCH_1).

1. Click the Coincidence command.

2. Select Axis in the Specification tree. You cannot select it in the geometry area because its geometry is not created. This axis is a published element, as indicated in the tree.

   The application detects it once selected. The axis is now highlighted in the geometry.

3. Select one of the two inner faces of CRIC_BRANCH_1 to select the associated axis.
As the coincidence constraint is created, CRIC_SCREW and CRIC_BRANCH_1 are aligned:

4. Now, you are going to set a contact constraint between CRIC_SCREW and a circular face of CRIC_BRANCH_1.

To do so, click the Contact Constraint icon.
5. Select Face in the specification tree. This face is a published element too. The required face is selected:

![Image of selected face]

6. Select the red circular face in the direction opposite to the published face.

![Image of selected face and red cylinder]

As the contact constraint is created, the turquoise cylinder is located exactly on the red face.

![Image of assembly with contact constraint]
The created constraints are automatically updated because the automatic update mode is activated. As the color defining valid constraints is green, our constraints are green. The application allows you to customize constraint colors as explained in Customizing Constraints.

The assembly now looks like this:
Moving Constrained Components Using the Compass

This task consists in manipulating the assembly to check if the components react the way we want, i.e. according to the constraints we set in the previous task.

1. Drag and drop the compass onto the CRIC_SCREW. For details about how to use the compass, please refer to CATIA- Infrastructure User's Guide Version 5.

As the compass is snapped to the component, you can manipulate the component, but only the component.

2. Now, if you select the y axis on the compass, press and hold down the Shift key, then drag and drop the component up and down, you can see that three components are moving.

This is an example of what we can get:
3. Repeat the operation as many times as you wish.

The assembly reacts correctly. The CRIC_FRAME component does not move because it is fixed. The other three components can move.

4. Release the left mouse button before releasing the Shift key.

5. Drag the compass away from the selected object and drop it.
Adding and Renaming a New Component

This task consists in adding a new component to the assembly. You will then rename this component. This component is a part created in the Part Design workbench.

1. Click Product1 and select the Add New Part... contextual command.

The New Part; Origin Point dialog box appears, presenting two possible options:

Either you define the point of your choice to locate the new part, or you use the origin point of the assembly as the origin point to be used for the part.

2. Click No to use the origin point of the assembly.

The new component "Part5 (Part5.1) is now displayed in the specification tree:
If the Manual Input option is activated (see Defining the Default Part Number), the Part Number dialog box appears before the New Part: Origin Point dialog box and lets you enter the name of your choice.

3. Click Part5 (Part5.1) and select the Properties... contextual command.

4. In the Properties dialog box that appears, click the Product tab. The options available have been designed to let you enter the information you required.
5. Enter CRIC_JOIN in the Part Number field and CRIC_JOIN.1 in the Instance name field.

6. Click OK to validate the operation.

The new names are now displayed in the specification tree:
Designing a Part in an Assembly Context

This task consists in designing the part you have just added to the assembly. It shows you how easy it is to access the tools required for designing components in an assembly context.

1. Double-click CRIC_Join in the specification tree to access the Part Design workbench.

2. Select the blue face as shown and click the Sketcher icon to access the Sketcher workbench.

3. Now that you are in the Sketcher, sketch a circle on the face using the circle command. Do not bother about positioning the circle.
4. Now to obtain the same radius value as the one used for the circular edge and make sure the circle and the circular edge share the same axis, use the Constraint command to create a coincidence constraint.

After validating the operation, the circle is coincident with the circular edge. You should obtain this:
5. Use the Pad command with the Up to Plane option to extrude the sketched circle. Select the blue face as shown to specify the limit of the pad.

After validating the operation, you should obtain this cylinder:

The part is designed.

<table>
<thead>
<tr>
<th>Up</th>
<th>Entering the Assembly Design</th>
<th>Fixing a Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inserting an Existing Component</td>
<td>Setting Constraints</td>
<td>Moving</td>
</tr>
<tr>
<td>Adding and Renaming a New Component</td>
<td>Designing a Part in Assembly</td>
<td>Editing a Parameter</td>
</tr>
<tr>
<td>Replacing a Component</td>
<td>Analyzing Constraints</td>
<td>Reconnecting Constraints</td>
</tr>
<tr>
<td>Detecting Clashes</td>
<td>Editing and Modifying a Component</td>
<td>Bill of Material</td>
</tr>
<tr>
<td>Exploding the Assembly</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Editing a Parameter

In this task, you are going to edit the diameter of the pocket belonging to CRIC_BRANCH_3. You will see how this edition affects the part you created in the previous task.

1. Double-click CRIC_BRANCH_3 to access the Part Design workbench.
2. Select the Pocket.2 item and use the Edit Parameters contextual command to display the associated parameters.

3. Double-click D11 in the geometry area to display the Constraint Edition dialog box.

4. Enter 20 as the new diameter value and click OK to compute the new pocket.

5. Update Product1 by double-clicking on Product1 in the specification tree.
The pocket is modified accordingly. The coincidence previously set between the two parts is maintained.
Replacing a Component

This task shows you how to replace Sub_Product1.CATProduct by another component.

1. Select Sub_Product1.CATProduct in the specification tree.

2. Select the Replacement Component contextual command.

3. In the dialog box that appears, select Sub_Product2.CATProduct as the replacement component and click Open.

Sub_Product1.CATProduct is no longer visible. This is Sub_Product2.CATProduct:

Note that the coincidence constraint is maintained. This is due to the publication of the axis used in the constraint definition. As the axis is a published element, the application can reconnect the constraint.
Analyzing Assembly Constraints

This task shows you how to analyze the status of all assembly constraints defined for Product1.

1. Select the Analyze -> Constraints... command.

The Constraints Analysis dialog box that appears displays all the information you need. The Constraints tab contains a detailed status of the assembly: the number of non constrained components and the status of the defined constraints.

2. Click the Broken tab to see the list of broken constraints. We have only one broken constraint, a contact constraint.

3. Click on the name of the constraint.

The constraint is highlighted in the specification tree.

Reconnecting this contact constraint is our next task.
Up
Inserting an Existing Component
Adding and Renaming a New Component
Replacing a Component
Detecting Clashes

Entering the Assembly Design
Setting Constraints
Designing a Part
Analyzing Constraints
Editing and Modifying a Component
Exploding the Assembly

Fixing a Component
Moving
Editing a Parameter
Reconnecting Constraints
Bill of Material
Reconnecting a Broken Constraint

In this task, you will learn how to reconnect the broken constraint detected by the application.

1. Double-click the broken constraint in the specification tree. Note that this broken constraint is indicated by a yellow warning symbol.

2. In the Constraint Edition dialog box that appears, click More to access additional information.

3. Click Disconnected in the Status frame, then Reconnect...

4. You are then prompted to select a component to rebuild the constraint. Select the same face as the one used for setting the first contact constraint. If you need some help, refer to Setting Constraints Between Components.

5. Click OK to validate the operation.

The constraint is reconnected:
Up
Inserting an Existing Component
Adding and Renaming a New
Replacing a Component
Detecting Clashes
Entering the Assembly Design
Setting Constraints
Designing a Part
Analyzing Constraints
Editing and Modifying a Component
Exploding the Assembly
Fixing a Component
Moving
Editing a Parameter
Reconnecting Constraints
Bill of Material
Detecting Clashes

In this task, you will learn how to detect possible clashes between two components.

1. Select CRIC_BRANCH_1.1.

2. Select the Analyze -> Compute Clash... command.

The Clash Detection dialog box appears. It displays the first component selected for computing possible clashes.

3. As you need another component, select SUB_PRODUCT2 using the Ctrl key. This component also appears in the dialog box.

4. Click Apply to compute clashes.

The application detects a clash between the brown cylinder and the red face. This is indicated by two red circles in the geometry, as the arrow shows in the figure below:
The result of the computation also appears in the dialog box.

Well, now that you know that your assembly needs to be modified to work properly, let's edit the cylinder.
Editing a Component

This task shows you how to edit the component causing the problem.

1. Double-click the brown cylinder to access the Part Design workbench.

2. Double-click the cylinder again to edit it. The Pad definition dialog box is displayed.
3. Enter 20mm to reduce the pad length and click OK.

4. The cylinder is updated and now looks like this:
Up

- Inserting an Existing Component
- Adding and Renaming a New Component
- Replacing a Component
- Detecting Clashes

Entering the Assembly Design

- Setting Constraints
- Designing a Part
- Analyzing Constraints
- Editing and Modifying a Component
- Exploding the Assembly

Fixing a Component

- Moving
- Editing a Parameter
- Reconnecting Constraints
- Bill of Material
Displaying the Bill of Material

This task shows you how to access all the information available about the structure of the assembly.

1. Select the Analyze -> Bill of Material... command.

The Bill of Material is displayed.
It is composed of three main sections:

- Bill of Material: lists all parts and sub-products one after the other
- Recapitulation: displays the total number of parts used in the product
- Listing Report: displays the tree of the product using indents

2. If you wish, you can save this document using the html format or the txt format. Just click the Save As... button, then give a name and the appropriate extension to your file.

For more information about the bill of material, please refer to Displaying the Bill of Material.
Exploding the Assembly

This last task illustrates the use of the Explode capability. Exploding the view of an assembly means separating the components of this assembly to see their relationships.

1. Make sure Product 1 is selected.

2. Click the Explode icon.

The Explode dialog box is displayed.
Product 1 is the assembly to be exploded. The Depth parameter lets you choose between a total (All levels) or partial (First level) exploded view.

3. Set All levels if not already set.

4. Set 3D to define the explode type.

5. Click Apply to perform the operation.

The Scroll Explode field gradually displays the progress of the operation. The application assigns directions and distance.

Once complete, the assembly looks like this:

The usefulness of this operation lies in the ability of viewing all components separately.

6. Click OK to validate the operation or click Cancel to restore the original view.
Well, you have done all the tasks of the Getting Started section. Why not consult the rest of the documentation?
Basic Tasks

*CATIA - Assembly Design* allows you to perform the following basic tasks:

- Creating an Assembly Document
- Managing Assembly Components
- Assembly Constraints
- Analyzing an Assembly
- Moving Components
- Using Assembly Tools
Creating an Assembly Document

This task will show you how to enter the Assembly Design workbench to create a new assembly from scratch.

1. Select the Start -> Mechanical Design -> Assembly Design command to launch the required workbench.

The Assembly Design workbench is opened. The commands for assembling different components are available in the toolbar to the right of the application window. You can see that “Product1” is displayed in the specification tree, indicating the building block of the assembly to be created.

It contains:

- a specification tree to the left of the application window
- specific toolbars to the right of the application window
- a number of contextual commands available in the specification tree and in the geometry. Note that these commands can also be accessed from the menu bar.
To find out how to design an assembly, refer to **Managing Assembly Components**.
Managing Assembly Components

This section describes the notions and operating modes you will need to design and manage your assembly structure.
About Assembly Components

Here are some basic rules you should know before handling the different types of files available in the Assembly workbench.

- No distinction is made between assemblies, subassemblies, and components in the description of the product structure. However, you can associate a geometric representation to one component only.
- If two instances of the same component are used in an assembly, there is only one reference component for both instances, i.e. any modifications to the reference affect every instance.
- An assembly is contained in a unique CATProduct file. The references of components and subassemblies can be contained in the same file as the assembly or in different CATProduct files.
  - If the reference is contained in the same file, the component can be used only in this assembly or in larger assemblies containing this assembly.
  - If the reference is contained in a different file, the component can be used in any assembly, but this file is then dedicated to this component only.
- When you use a file as a representation (.model, .cgr, .ncgm) assembly data (part number, definition) is saved in a different CATProduct file.
- A CATPart file contains the assembly data related to the part and the reference of this component.
Inserting a New Component

This task will show you how to insert a component into an existing assembly.

This command lets you:
- create an instance from the reference chosen component
- use a context-specific representation inside it (see Managing Representations).

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. In the specification tree, select ManagingComponents01 and click the New component icon. This command is also available from the Insert menu and contextual menu.

The structure of your assembly now includes Product2(Product21.1).
<table>
<thead>
<tr>
<th>Up</th>
<th>About Assembly Component Inserting a New Component</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Inserting a New Part</td>
</tr>
<tr>
<td></td>
<td>Unloading Components</td>
</tr>
<tr>
<td></td>
<td>Modifying the Properties of</td>
</tr>
<tr>
<td></td>
<td>Managing Representations</td>
</tr>
<tr>
<td></td>
<td>Defining a Multi-Instantiation</td>
</tr>
<tr>
<td></td>
<td>Inserting Documents</td>
</tr>
</tbody>
</table>
Inserting a New Part

This task will show you how to insert a part in an existing assembly.

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. In the specification tree, select ManagingComponents01 and click the New Part icon.

This command is also available from the Insert menu and contextual menu.

If geometry exists in the assembly, the New Part: Origin Point dialog box is displayed, proposing two options to locate the part:

- Click Yes to locate the part origin point on a selected point, on another component for example.
- Click No to define the origin point of a component according to the origin point of the parent component

2. For the purposes of this task, click No to locate the part origin according to the Product1 origin point.

The Part8 (Part8.1) is created in the specification tree.
To edit Part8 or any other subelements of the CATPart document, double-click on the component of interest in the specification tree and you will access the Part Design workbench. See *CATIA - Part Design User’s Guide V5* for more information.

Do not mistake the Product document for the Part Design document:

- The Product document is identified with the Product document icon 
  
- The Part Design document is identified with the Part Design document icon 


decor
Inserting Existing Components

This task will show you how to import one or more components into an existing assembly.

You can import the following document types:

- CATProduct
- CATPart
- model
- session

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. In the specification tree, select ManagingComponents01 and click the Existing component icon. This command is also available from the Insert menu.

   The Insert an Existing Component dialog box is displayed.

2. Select CRIC_TOP.CATPart in the SAMPLES directory and click Open.

   The CRIC_TOP (CRIC_TOP.1) is created in the specification tree and the part is displayed in the geometry area.
You can specify the order in which the files will be imported when you select the files in the Insert an Existing Component dialog box.
Loading Components

This task will show you how to load a component into an assembly.

Loading a component means loading its geometry, having its geometry in memory.

You can only load **CATPart** and **CATProduct** documents in an assembly. For a **model** document, you must use the activate representation functionalities, see [Activating a Representation](#).

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select CRIC_BRANCH_3 (CRIC_BRANCH_3.1) in the specification tree or in the geometry and select Edit -> Load.

   CRIC_BRANCH_3 (CRIC_BRANCH_3.1) is loaded:
   - The link symbol disappears from the document icon in the specification tree
   - The geometry of the component is displayed.

   ![ManagingComponents01](image)
Unloading Components

This task will show you how to unload a component from an assembly.

Unloading a component means removing its geometry from the system memory.

You can only unload CATPart and CATProduct documents in an assembly. For a model document, you must use the deactivate representation functionalities, see Activating a Representation.

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select CRIC_BRANCH_3 (CRIC_BRANCH_3.1) in the specification tree or in the geometry and select Edit -> Unload.

CRIC_BRANCH_3 (CRIC_BRANCH_3.1) is unloaded:

- A link symbol appears in the bottom left corner on the document icon in the specification tree to indicate an unloaded document.
- The geometry of the component disappears.
If the component to be unloaded has been modified, the Unload document dialog box is displayed with three options:

- Click **Yes** if you want to save the document to be unloaded
- Click **No** if you do not want to save the document to be unloaded
- Click **Cancel** if you want to quit the Unload command.
Replacing a Component

This task consists in replacing a component. Using the Replacement Component command means replacing one component with another.

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select CRIC_SCREW (CRIC_SCREW.1) and click the Replacement Component icon. This command is also available from the Edit menu and contextual menu.

The Replace a Component dialog box is displayed.

2. Select CRIC_SCREW_2.CATPart in the SAMPLES directory.

The component is replaced in the specification tree and in the geometry area.

The ManagingComponents01 document contains the following components:

- CRIC_AXIS (CRIC_AXIS.1)
- CRIC_FRAME (CRIC_FRAME.1)
- CRIC_SCREW_2 (CRIC_SCREW.1)
- CRIC_TOP (CRIC_TOP.1)
- Set1 (Set1.1)
  - CRIC_BRANCH_1 (CRIC_BRANCH_1.1)
  - CRIC_BRANCH_3 (CRIC_BRANCH_3.1)
  - CRIC_JOIN (CRIC_JOIN.1)
Only the constraints linked to the same published element will be reconnected, others may be broken.
See Managing the Product Publication for more information.
Editing Components

This task lists the ways of editing components in an existing assembly.

The **Cut** command removes the selected component instance and puts them on the clipboard.
The **Copy** command puts a copy of the selected component instance into the clipboard.
The **Paste** command creates a new component instance from the clipboard.
The **Delete** command removes the selected component instance.
The **Drag and Drop** capability allows you to copy or move one component to another.

For each edition operation you must select the components in the specification tree.

Remember that the components you wish to move or paste may have one or more constraints.
Once the component is moved or pasted, the constraints may be broken. See also [Setting the Paste Component Behavior](#).
Modifying Component Properties

This task shows you how to access and edit component properties. You can redefine and even create new ones at any time.

Open the ManagingComponents01.CATProduct document from the online\samples\AssemblyDesign directory.

1. Right-click on CRIC_AXIS (CRIC_AXIS.1) in the specification tree and select Properties from the contextual menu.

You can select the component in the specification tree or in the geometry. This command is also available from the Edit menu.

The Properties dialog box is displayed. Three tabs are available:
- Graphic
- Product
- Mechanical

2. Click the Mechanical tab to display the mechanical properties of the selected component:
- Characteristics: Volume, Mass and Surface The fields are not editable. Note that the mass is 0kg because no material has been applied. For more about materials, please refer to CATIA Real Time Rendering User's Guide.
- Inertia center The corresponding fields are not editable.
- Inertia Matrix The corresponding fields are not editable.
3. Click the Product tab in the Properties dialog box.

This tab displays the Product properties, Component properties and the Define other properties button.
The Product frame displays:
- Part Number, the name of the product
- Revision, the revision of the product
- Definition, the definition of the product
- Nomenclature, the nomenclature of the product
- Source, the origin of the product
  The combo box displays the following options:
  - unknown, for an unknown product
  - made, for a product made by the user
  - bought, for a product bought by the user.
- Description, the description of the product.

The Component frame displays:
- Instance name, the name of the selected component
- Description, the description of the selected component.

4. Click the Define other properties... button.
The dialog box that appears lets you add the properties of your choice.
Here is the list of the new parameters you can add:

- Real
- Integer
- String
- Boolean
- Length
- Angle
- Time
- Mass
- Volume
- Density
- Area
- Inertia Moment
- Energy
- Force
- Inertia
- Massic Flow
- Moment
- Pressure
- Angular Stiffness
- Temperature
- Linear Mass
- Linear Stiffness
- Volumetric Flow
- Frequency
- Electric Power
- Voltage
- Electric resistance
- Electric intensity
5. Select the parameter you need next to New Parameter of type. For example, select String, then click New Parameter of type. This parameter displays in the property name frame.

6. Rename the parameter as Manufacturer in the Edit and value field.

7. Enter French Company in the value field.

The dialog box now looks like this:

![Image of Define other properties dialog box]

Clicking Delete parameter deletes the selected parameter.

Clicking External properties... accesses additional properties defined in a .txt or .xls file. The application can reuse these files provided they have a tabulated format.

What you need to do is just select the desired file in the Open File dialog box that displays.
8. Click OK in the Define other properties dialog box to validate the creation of the property.

A new section Product:Added Properties appears in the Properties dialog box. This section displays all the properties you have created, even those described in the .txt or .xls files.

Once created, you can access these properties via the Bill of Material too.

5. Now, click the Graphic tab in the Properties dialog box.
This tab lets you display the Graphic properties of the component. To know how to apply graphic properties, refer to *CATIA- Infrastructure User's Guide Version 5*.

4. Click OK to validate the operation.
Design Mode

This task shows you how to set the design mode for components in the Assembly Design context.

The **Design Mode** command changes the **cgr** format of the component into the original editable component document. In other words, geometric data is available. This explains why most of the commands are available if Design Mode is activated.

You may wish to use the other edition mode referred to as the **Visualization Mode** (see [Visualization Mode](#)).

This functionality is available if you possess a Digital Mock-Up (DMU) Navigator license.

Make sure that the Work with the cache system setting is activated. For more information, see [Using the Cache Memory](#).

Open the ManagingComponents01.CATProduct document from the `\online\samples\AssemblyDesign` directory.

1. Select Set1 (Set1.1).

2. Select Edit -> Design Mode.

The child component geometrical elements in Set1 (Set1.1) may be selected and their branches are expandable. The + sign shows it.
You can select the root of several components to apply the design mode or visualization mode functionalities.
Visualization Mode

This task shows you how to set the visualization mode for components in the Assembly Design context.

The **Visualization Mode** uses documents in **cgr** format. Only the external appearance of the component is visualized. The geometry is not available, which may be useful when you deal with sophisticated assemblies with large amounts of data but only need a few components to work on.

You may wish to use the other edition mode referred to as the **Design Mode** (see [Design Mode](#)).

This functionality is available if you possess a Digital Mock-Up (DMU) Navigator license.

Make sure that the Work with the cache system setting is activated. For more information, see [Using the Cache Memory](#).

Open the ManagingComponents01.CATProduct document from the `\online\samples\AssemblyDesign` directory.

1. Select Set1 (Set1.1).

2. Select Edit -> Visualization Mode.

The child component geometrical elements in Set1 (Set1.1) cannot be selected and their branches are not expandable.
You can select the root of several components to apply the visualization mode functionality.
Managing Representations

This task describes the notions and operating modes you will need to use a context-specific representation in your assembly structure.

A context-specific representation is a hierarchical design of an assembly in a specific context. For this version you can only use a geometrical representation from a Version 4 model document.

Once you have created a new component or inserted a Version 4 model as an existing component in an assembly, you can associate, remove, replace, rename, activate or deactivate a context-specific representation to this product.

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

If you possess a Digital Mock-Up (DMU) Navigator license, the model is read as .cgr format, you may convert it to .model format with the Design Mode command. See Edition Mode.

1. Select a product in the specification tree.

2. Click the Manage Representations icon.

The Manage Representations dialog box appears.

It displays:
- the Name of the representation
- the Source file of the representation
- the Type of representation
- whether the representation is the Default representation of the product
- whether the representation is Activated or not.

3. Click the Associate... button.

The Associate Representation dialog box is displayed.

4. Select the .model document from the samples/AssemblyDesign directory and click Open.

The representation is associated with Product and displayed in the specification tree and in the geometry area. The representation is activated and set as the default representation.

You can associate as many representations as you need, but only one must be set as default. In this case other representations are not displayed in the specification tree and in the geometry area. To change the default representation of a product, select one of its representations and click the Set As Default button.

5. Select a representation in the Manage Representations dialog box and click the Deactivate button.
The representation is deactivated from Product in the specification tree and in the geometry area and No is displayed in the Activated column of the Manage Representations dialog box.

6. Select the same representation in the Manage Representations dialog box and click the Activate button.

The representation is activated from Product in the specification tree and in the geometry area, and yes is displayed in the Manage Representations dialog box, Activated column.

7. Select a representation in the Manage Representations dialog box and click the Replace... button.

The Replace Representation dialog box is displayed.

8. Select the model document from the samples/AssemblyDesign directory and click Open.

The representation is replaced in Product in the Specification Tree, in the geometry area and in the Manage Representations dialog box.

When you replace a constrained representation, even if its constraints have been deleted, you are in the reconnect representation context.

See Reconnecting a Replaced Representation.

When you replace a deactivated representation, the replacing representation is automatically activated.

If you possess a Digital Mock-Up (DMU) Navigator license, the model is read as .cgr format, you may convert it in .model format with the Design Mode command. See Edition Mode.

9. Select a representation in the Manage Representations dialog box and click the Rename... button.

The Rename Representation dialog box is displayed.

10. Define a new name or select an existing name in the combo box.

The representation is renamed in Product in the specification tree and in the Manage Representations dialog box.

11. Select a representation in the Manage Representations dialog box and click the Remove button.

The representation is removed from Product in the specification tree, in the geometry area and in the Manage Representations dialog box.
Defining a Multi-Instantiation

This task shows you how to repeat components as many times as you wish in the direction of your choice.

Open the Multi_Instantiation.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select the component you wish to instantiate, that is CRIC_BRANCH_3.

2. Click the Define Multi-Instantiation icon.

The Multi-Instantiation dialog box is displayed, indicating the name of the component to be instantiated.

The shortcut Ctrl + D calls the command too.
The Parameters option lets you choose between the following categories of parameters to define:

- Instances & Spacing
- Instances & Length
- Spacing & Length

3. Keep the Instances & Spacing parameters option and enter 3 as the number of instances and 90mm as the value for the spacing between each component.

4. To define the direction of creation, check x axis.

There are other ways of defining a direction. You can select a diagonal button or even select a line, axis or edge in the geometry. In this case, the coordinates of these elements appear in the Result field.

Clicking the Reverse button reverses the direction.
5. Make sure the option Define as Default is on. If it is so, the parameters you have just defined are saved and will be reused by the Fast Multi-Instantiation command.

6. Click OK to create the components.

Three additional components are created in the x direction. The tree displays them as well.
This task shows you how to repeat components using the parameters previously set in the Define Multi_Instantiation command.

You will use the Fast Multi-Instantiation command to quickly repeat the component of your choice. The operation is very simple.

Open the Fast_Multi_Instantiation.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select the component you wish to instantiate, that is CRIC_BRANCH_3.

2. Click the Fast Multi-Instantiation icon .

The shortcut Ctrl + E calls the command too.

The result is immediate. Three components are created according to the parameters defined in the Multi-Instantiation dialog box.
Inserting CATPart or CATProduct Documents from a Catalog

This task shows you how to copy CATPart or CATProduct documents from a catalog into an existing assembly.

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Open a catalog, for example the FASTENERS.catalog that you created in Creating a Catalog. Double-click on the main chapter, FASTENERS. Find the chapter containing the entity you want to copy into the assembly.

2. Double-click on this chapter, SCREWS for example. The following dialog box appears:
3. Click on the entity you wish to copy and select the Edit->Copy command.

4. Select the appropriate target i.e. the main product item or any CATProduct document in the specification tree and retrieve the entity from the clipboard using the Edit->Paste command.
Using Assembly Constraints

This section describes the notions and operating modes you will need to set and use constraints in your assembly structure.

Constraints allow you to position mechanical components correctly in relation to the other components of the assembly. You just need to specify the type of constraints you wish to set up between two components, and the system will place the components exactly the way you want.

You can also use constraints to indicate the mechanical relationships between components. In this case, constraints are included in the specifications of your assembly.
About Assembly Constraints

Setting constraints is rather an easy task. However, you should keep in mind the following:

- You will apply constraints only between the child components of the active component.
- You cannot define constraints between two geometric elements belonging to the same component.
- You cannot apply a constraint between two components belonging to the same subassembly if this subassembly is not the active component.

The following figure illustrates what you are allowed to do:
(1) The constraint cannot be applied because Product K does not belong to the active component Product B. To define this constraint, Product A must be made active.

(2) The constraint cannot be applied because Product E and Product F both belong to a component other than the active component Product B. To define this constraint, Product D must be made active.

(3) The constraint can be applied since Product C belongs to the active component Product B and also Product E is contained within Product D which is contained within the active component Product B.

Symbols

The following table lists the symbol used to represent the constraints you can set between your components:

<table>
<thead>
<tr>
<th>Constraints</th>
<th>Symbol used in the geometry area</th>
<th>Symbol displayed in the Specification tree</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coincidence</td>
<td><img src="image" alt="Coincidence Symbol" /></td>
<td><img src="image" alt="Coincidence Symbol" /></td>
</tr>
<tr>
<td>Contact</td>
<td><img src="image" alt="Contact Symbol" /></td>
<td><img src="image" alt="Contact Symbol" /></td>
</tr>
<tr>
<td>Offset</td>
<td><img src="image" alt="Offset Symbol" /></td>
<td><img src="image" alt="Offset Symbol" /></td>
</tr>
<tr>
<td>Angle</td>
<td><img src="image" alt="Angle Symbol" /></td>
<td><img src="image" alt="Angle Symbol" /></td>
</tr>
<tr>
<td>Planar Angle</td>
<td><img src="image" alt="Planar Angle Symbol" /></td>
<td><img src="image" alt="Planar Angle Symbol" /></td>
</tr>
</tbody>
</table>
Note also that deactivated constraints are preceded by this symbol: \( ( ) \) in the Specification tree.

The application lets you customize the creation of constraints. Please refer to Setting the Constraints Creation.

Do not mistake the active component for the selected component:

- The active component is blue framed (default color) and underlined. It is activated by double-clicking.
The selected component is orange framed (default color). It is selected by clicking.

When you set a constraint, there are no rules to define the fixed and the moved component during the selection. If you want to fix a component, use the Fix command. See Fixing a Component.
Creating a Coincidence Constraint

Coincidence type constraints are used to align elements. Depending on the selected elements, you may obtain concentricity, coaxiality or coplanarity. The tolerance i.e. the smallest distance that can be used to differentiate two elements is set at 10\(^{-3}\) millimeters.

The following table shows the elements you can select.

<table>
<thead>
<tr>
<th></th>
<th>Point</th>
<th>Line</th>
<th>Plane</th>
<th>Planar Face</th>
<th>Sphere (point)</th>
<th>Cylinder (axis)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plane</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Planar Face</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sphere (point)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cylinder (axis)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This task consists in applying a constraint between two faces.

Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue framed and underlined).

Open the AssemblyConstraint01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Coincidence constraint icon
This command is also available from the Insert menu.

2. Select the face to be constrained, that is the red face as shown.

3. Select the second face to be constrained, that is the blue circular face in the direction opposite to the red face.

The Constraint Properties dialog box that appears displays the properties of the constraint. The components involved and their status are indicated. You can define the orientation of the faces to be constrained by choosing the Opposite or Same option.

For our scenario, keep the Opposite option.
4. Click OK to create the coincidence constraint.

As the coincidence constraint is created, the red component is moved so as to adopt its new position. Green graphic symbols are displayed in the geometry area to indicate that this constraint has been defined.

This constraint is added to the specification tree too.

Graphic symbols used for constraints can be customized. For more information, refer to [Setting the Constraints Appearance](#).
Creating a Contact Constraint

Contact type constraints can be created between two planes or faces.

The common area between the two planes can be a plane (plane contact), a line (line contact) or a point (point contact).

The following table shows the elements you can select. Assembly Design V5R3 provides additional possibilities for creating contact constraints as indicated by the blue color.

<table>
<thead>
<tr>
<th></th>
<th>Planar Face</th>
<th>Sphere</th>
<th>Cylinder</th>
<th>Cone</th>
<th>Circle</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planar Face</td>
<td><img src="image1" alt="Image" /></td>
<td><img src="image2" alt="Image" /></td>
<td><img src="image3" alt="Image" /></td>
<td><img src="image4" alt="Image" /></td>
<td><img src="image5" alt="Image" /></td>
</tr>
<tr>
<td>Sphere</td>
<td><img src="image6" alt="Image" /></td>
<td><img src="image7" alt="Image" /></td>
<td><img src="image8" alt="Image" /></td>
<td><img src="image9" alt="Image" /></td>
<td><img src="image10" alt="Image" /></td>
</tr>
<tr>
<td>Cylinder</td>
<td><img src="image11" alt="Image" /></td>
<td><img src="image12" alt="Image" /></td>
<td><img src="image13" alt="Image" /></td>
<td><img src="image14" alt="Image" /></td>
<td><img src="image15" alt="Image" /></td>
</tr>
<tr>
<td>Cone</td>
<td><img src="image16" alt="Image" /></td>
<td><img src="image17" alt="Image" /></td>
<td><img src="image18" alt="Image" /></td>
<td><img src="image19" alt="Image" /></td>
<td><img src="image20" alt="Image" /></td>
</tr>
<tr>
<td>Circle</td>
<td><img src="image21" alt="Image" /></td>
<td><img src="image22" alt="Image" /></td>
<td><img src="image23" alt="Image" /></td>
<td><img src="image24" alt="Image" /></td>
<td><img src="image25" alt="Image" /></td>
</tr>
</tbody>
</table>

This task consists in applying a constraint between two faces.

Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue framed and underlined).

Open the AssemblyConstraint01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Contact constraint icon.

This command is also available from the Insert menu.
2. Select the face to be constrained, that is the red face as shown.

3. Select the second face to be constrained, that is the blue face in the direction opposite to the red face.

As the contact constraint is created, the red component is moved so as to adopt its new position. Green graphic symbols are displayed in the geometry area to indicate that this constraint has been defined.

This constraint is added to the specification tree too.
Graphic symbols used for constraints can be customized. For more information, refer to **Setting the Constraints Appearance**.
Creating an Offset Constraint

When defining an offset constraint between two components, you need to specify how faces should be oriented.

The offset value is always displayed next to the offset constraint.

The unit used is the unit displayed in the Units tab of the Tools -> Options dialog box. If you wish, you can customize it.

The following table shows the elements you can select:

<table>
<thead>
<tr>
<th></th>
<th>Point</th>
<th>Line</th>
<th>Plane</th>
<th>Planar Face</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td></td>
</tr>
<tr>
<td>Line</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td></td>
</tr>
<tr>
<td>Plane</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
</tr>
<tr>
<td>Planar Face</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
</tr>
</tbody>
</table>

This task consists in applying an offset constraint between two faces.

Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue framed and underlined).

Open the AssemblyConstraint02.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Offset constraint icon.

This command is also available from the Insert menu.

2. Select the face to be constrained, that is the yellow face as shown.

3. Select the second face to be constrained, that is the blue face in the direction opposite to the yellow face.
The Constraint Properties dialog box that appears displays the properties of the constraint. The components involved and their status are indicated. You can define the orientation of the faces to be constrained by choosing the Opposite or Same option.

For our scenario, keep the Opposite option.

4. Enter 38 mm in the Offset field.

5. Click OK to create the offset constraint.

As the offset constraint is created, the blue component is moved so as to adopt its new position. A green arrow is displayed in the geometry area to indicate that this constraint has been defined. The offset value is displayed too.

This constraint is added to the Specification Tree too.

Graphic symbols used for constraints can be customized. For more information, refer to Customizing Constraints.
Creating an Angle Constraint

Angle type constraints fall into three categories:

- Angle
- Parallelism (angle value equals zero)
- Perpendicularity (angle value equals 90°)

When setting an angle constraint, you will have to define an angle value. Note that this angle value must not exceed 90°.

The tolerance i.e. the smallest angle that can be used to differentiate two elements is set at 10^-6 radians.

The following table shows the elements you can select:

<table>
<thead>
<tr>
<th></th>
<th>Line</th>
<th>Plane</th>
<th>Planar Face</th>
<th>Cylinder (axis)</th>
<th>Cone (axis)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plane</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Planar Face</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cylinder (axis)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cone (axis)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This task consists in applying an angle constraint between two planes.
Open the AssemblyConstraint03.CATProduct document from the \online\samples\AssemblyDesign directory.

Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue framed and underlined).

1. Click the Angle constraint icon.

This command is also available from the Insert menu.

2. Select the face to be constrained, that is the blue face as shown.

3. Select the second face to be constrained, that is the red face in the direction opposite to the blue face.
The Constraint Properties dialog box is displayed with the properties of the selected constraint and the list of available constraints:

- Perpendicularity
- Parallelism
- Angle
- Planar angle (an axis is to be selected. This axis must belong to both planes)

4. Keep the Angle option and set the Sector option to Sector3.

5. Enter 40 deg in the Angle field.

6. Click OK to create the angle constraint.

As the angle constraint is created, the red component is moved so as to adopt its new position. A green arrow is displayed in the geometry area to indicate that this constraint has been defined. The angle value is displayed too.

This constraint is added to the specification tree too.
Graphic symbols used for constraints can be customized. For more information, refer to Customizing Constraints.
Fixing a Component

Fixing a component means preventing this component from moving from its parent component during the update operation. Note that it does not mean fixing its position according to the geometrical origin of the assembly.

To fix the component location according to the geometrical origin of the assembly, check **Fix in space** in the constraint Properties dialog box.

This task consists in fixing a component.

Before fixing the desired component, make sure it belongs to a component defined as active.

Open the Fix.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Fix icon.

This command is also available from the Insert menu.

2. Select the component to be fixed, that is the light blue component.

The constraint is created. A green anchor is displayed in the geometry area to indicate that this constraint has been defined.

This constraint is added to the specification tree too.
Graphic symbols used for constraints can be customized. For more information, refer to Setting the Constraints Appearance.
Fixing Components Together

The **Fix Together** command attaches selected elements together. You can select as many components as you wish, but they must belong to the active component.

This task consists in fixing two components together.

Open the Fix.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Fix Together icon.

   This command is also available from the Insert menu and works both in design and visualization mode.

2. Select **CRIC_FRAME**.

3. Select **CRIC_BRANCH_3**.

   You can select the components in the specification tree or in the geometry area.

3. The Fix Together dialog box appears, displaying the list of selected components.

   To remove a component from the list, just click it.
4. In the Name field, enter a new name for the group of components you want to create. For instance, enter FT1.

5. Click OK.

The components are attached to each other. Moving one of them moves the other one too.

The specification tree displays this operation.

Because you can inadvertently move these components, the application displays a warning message to remind you that you are moving components fixed together. If you wish not to see such a message, just deactivate the display option. To know more about this option, refer to Setting Warning Message Display.
A Few Notes about Fix Together

- You can select a set of attached components to apply the Fix Together command between this set and other components.
- You can set constraints between components belonging to a set of components fixed together.
- If you set a constraint between a component and a set of attached components, the whole set is affected by the constraint.
Using the Autoconstraint Command

The Autoconstraint mode allows you to create the first possible constraint as specified in the priority list.

This task consists in using the Autoconstraint command to create two constraints.

Open the Autoconstraint.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Make sure the list specifying the order of constraint creation is composed as follows:
   1. Surface contact
   2. Coincidence
   3. Offset
   4. Angle
   5. Parallelism

   For more about this list, please refer to Setting the Autoconstraint Mode.

2. Double-click the Autoconstraint icon .

Select both axes as shown.
As the application cannot set a surface contact due to the type of selected elements, it creates the second optional constraint mentioned in the list, that is a coincidence constraint.

3. Now select the faces as shown:

The first constraint of the list can now be set. A surface contact constraint is created.

Graphic symbols used for constraints can be customized. For more information, refer to Setting the Constraints Appearance.
Changing Constraints

Changing a constraint means replacing the type of this constraint by another type. This operation is possible depending on the supporting elements. You can select any constraints, not necessarily in the active component.

This task consists in changing the parallelism constraint into an offset constraint.

Open the AssemblyConstraint05.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select the constraint to be changed.

2. Click the Change Constraint icon.

The Change Type dialog box that appears, displays all possible constraints.

3. Select the new type of constraint. For our scenario, select Offset.

4. Click Apply to previsualize the constraint in the specification tree and the geometry.
5. Click OK to validate the operation.
Deactivating or Activating Constraints

Deactivating or activating constraints means specifying if these constraints must be taken into account during updates or not. This task consists in deactivating then activating a constraint.

Open the GettingStarted.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select the activated constraint of interest.

   Any constraints can be used.

2. Click the Activate/Deactivate Constraints icon.

   This command is also available from the contextual menu.

   The constraint is deactivated. The graphic symbol representing the deactivated constraint is now displayed in white. Red brackets precede the constraint in the specification tree.
3. Repeat steps 1 and 2 to activate the selected constraint.
Selecting the Constraints of Given Components

This task consists in selecting all the constraints defined for a component. You can only select child components of the active component. The Component Constraints command allows you to select the constraints linked to one or several selected components. These components are child components of the active component.

Open the GettingStarted.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select the component which constraints are to be selected.
   Selecting several components is allowed too.

2. Right-click and select CRIC_FRAME.1 object -> Component Constraints contextual command.

This command in also available from the Edit menu.

The application highlights two constraints, both in the specification tree and the geometry area.
Selecting Hidden Geometric Elements

This task shows you how to select the hidden geometric elements of a component for setting a coincidence constraint.

1. Click the Coincidence constraint icon

2. Select the axis of the cylinder.

3. Move the cursor onto the yellow part.

An orange cross is pre-selected to indicate the point as the top of the cone.

4. Press the Left Arrow key on your keyboard.

The axis of the yellow part is pre-selected.

The Graphic Selection Tool is displayed. Use the Left Arrow or Right Arrow keys to select the geometrical elements of the component.
5. Click the circle of the Graphic Selection Tool to validate. The constraint is created.

6. To exit the Graphic Selection Tool, click the circle of the tool to validate or move the cursor to undo the selection.
Updating an Assembly

Updating an assembly means updating its components as well as its constraints. The application lets you choose between updating the whole assembly or the components of your choice.

This task consists in updating the whole assembly.

Remember, two update modes are available. Before following the scenario, make sure the option Manual update is activated.

The constraints are black, indicating they need an update. If by default they are black, the application allows you to redefine the colors you want. To do so, please refer to Setting the Constraints Appearances.

1. Click the Update icon to update the whole assembly.
The assembly is updated.
Graphic symbols are green.

Now, if you wish to update some of the components, select the components of interest and use the Update contextual command. Note however that applying the contextual command on a component may sometimes induce a general update if the assembly is a complex one made of several components.
Updating One Constraint Only

When you need to update your constraints, either you update all the constraints of the active component or update one or several constraints of the active component.

By default, constraints needing an update are displayed in black. To redefine the colors of the constraints, please refer to Setting the Constraints Appearance.

This task consists in updating the constraints you explicitly specify.

1. Right-click the constraint to be updated.

Constraints needing an update are displayed with specific graphic properties. The Properties dialog box indicates too if constraints need updates or not. For more information, please refer to Modifying the Properties of a Constraint.

You can select the constraint in the specification tree or in the geometry.

2. Then select Update from the contextual menu.

The selected constraint is updated.

3. Now click the second constraint to be updated.

4. Control-right-click the third constraint to be updated.

5. Then select the Update contextual command.

The two selected constraints are updated too. Remember, valid constraints are green by default.
Modifying the Properties of a Constraint

This task consists in modifying the property of a constraint.

Open the AssemblyConstraint02.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Right-click the offset constraint to be modified.
   You can select the constraint in the specification tree or in the geometry.

2. Then select Properties from the contextual menu.
   The Properties dialog box is displayed.

   ![Properties Dialog Box]

   The Constraint tab displays the name of the constraint as well as the name of the support components. The status is also indicated. In our scenario, the constraint is connected. To know how to reconnect broken or misconnected constraints, please refer to Reconnecting Constraints.

4. Enter a new value in the Offset field. For example, enter 50 mm.

5. Set the Orientation option to Same so as to reverse the blue component.

6. Click the Mechanical tab.
7. Three attributes characterize constraints:
   - Deactivated: deactivated constraints are not taken into account when updating the assembly
   - To update: the constraint does not reflect the last changes to the assembly
   - Unresolved: the application detects troubles

6. Click Deactivated.

The constraint is modified accordingly.

Note that brackets precede the constraint value, indicating that the constraint is deactivated. These brackets precede the name of the constraint in the specification tree too. The color of the graphic symbol is modified.

The Graphic tab lets you define the graphic properties of your constraint. To know how to do so, please refer to CATIA- Infrastructure User's Guide Version 5.

Instead of using the properties contextual command as described in this task, you can double-click the constraint to be edited, which displays the related dialog box:
Using a Part Design Pattern

This task shows you how to repeat a component on a pattern created in Part Design.

Remember, three types of patterns are available:

- **Rectangular pattern**
- **Circular pattern**
- **User pattern**

Open the Pattern.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select the pattern of interest in the tree, that is the rectangular pattern as follows:

2. Select the component to repeat, that is the screw.

   Selecting a constraint linking a pattern to a component selects both the pattern and the component.

3. Click the Reuse Pattern icon.

   The Instantiation on a pattern dialog box is displayed, indicating the name of the pattern, the number of instances to be created (for information only) and the name of the component to repeat.
To define the first instance, three options are available.
- re-use the original component: the original component is located on the pattern, but remains at the same location in the tree.
- create a new instance: the original component does not move and a new one is created on the pattern.
- cut & paste the original component: the original component is located on the pattern and is moved in the tree.

4. For our scenario, make sure the option re-use the original component is on.

5. Now in the Re-use Constraints section you can define if you wish to reproduce the original constraints or not by checking one of the following options:
   - All
   - None
   - Selected

6. For our scenario, choose the Selected option.

You can notice that the field below displays the constraints detected. To unselect a constraint, just click on it.

7. To control the display of the components in the tree, two options are available: either you check the option Put new instances in a component to gather all instances in the same component, or not. Check the option.

8. Click OK to repeat the screw.

31 instances are created on the pattern. The original component remains at the same location and the new component is displayed in the tree.
Analyzing an Assembly

This section describes the different tools you can use to analyze and control your assembly structure.
Computing a Clash Between Components

Because assemblies may be very complex and include a lot of components, you may find it difficult to see possible clashes. This task shows you how to analyze clashes or clearance between components.

Open the AnalyzingAssembly01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select Analyze -> Compute Clash...
   The Compute Clash dialog box is displayed. It lets you compute possible clashes or clearance. The default option is Clash.
2. Multiselect the components: CRIC_FRAME1 and CRIC_BRANCH_3.
   The components are displayed in the Compute Clash dialog box.
3. Click Apply to compute a possible clash.
   The icon of the Result frame now is red indicating that an interference has been detected.
The application detects a clash between the components. This result is materialized by two red areas as the arrow shows in the figure opposite:

4. Click Cancel.
5. Repeat the operation to compute a possible clash between CRIC_BRANCH1 and CRIC_BRANCH_3.

The application detects a contact between the components. The icon of the Result frame now is yellow indicating this.
6. Click Cancel to exit.

7. Repeat the operation to compute a possible clash between CRIC_JOIN1 and CRIC_BRANCH_1.1.

The icon of the Result frame is green indicating that no interference has been detected.
Computing a Clearance Between Components

Once components have been added or constrained, you may need to analyze the clash or the clearance between components. This task shows you how to compute the clearance between two components of an Assembly.

Open the AnalyzingAssembly01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select Analyze -> Compute Clash.
   The Clash Detection dialog box is displayed.

2. Select Clearance in the combo box.
   The Compute Clash dialog box displays a field where you specify the clearance value.

3. Enter the clearance value: 50 mm

4. Click the first component: CRIC_JOIN.1.

5. Control-click the second component: CRIC_BRANCH_3.1.
   The components are displayed in the Clash Detection dialog box.

6. Click Apply to compute possible clearance.

   The application detects a clearance violation. The distance between the components is inferior to the 50mm. The status icon is yellow in the dialog box.
7. Click Cancel to perform another operation.

8. Now multiselect CRIC_BRANCH_3 and CRIC_BRANCH_1.

9. Repeat steps from 1 to 3.

10. Click Apply.

The application detects a contact between the components. The status icon is yellow in the dialog box.
11. Click Cancel to exit.
Displaying the Bill of Material

This task shows you how to display the number and name of the components included into the active component as well as the properties of these components. It also shows you how to save this data.

You can display the bill of material of the active component only.

Open the AnalyzingAssembly01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select Analyze -> Bill of Material.

The Bill of Material dialog box is displayed. It is composed of two tabs:

- Bill of Material
- Listing Report

The Bill of Material tab shows the different parts and sub-assemblies of the AnalyzingAssembly01 which is the active component.

There are three main sections:

- Bill of Material:xxx : lists all parts and sub-products one after the other
- Recapitulation: displays the total number of parts used in the product
- Formats  AnalyzingAssembly01.CATProduct
2. Click Save As to save this data.

The Save Bill of Material As dialog box is displayed.

Three document formats are available: **Bom_txt** as text format, **Bom_html** as html format and **.xls** as Excel format.

3. Select the appropriate directory and enter a name in the File name field.

Note that the file generated will contain the date of generation.

4. Now click the Formats button to customize the display of your bill of material.

A new dialog box appears, indicating the default format, that is AP203 format.

5. To create the format of your choice, click on Add.

Format.1 then appears in the Selected Format.

The Rename button is used for renaming already existing formats. The Remove button is used for removing already existing formats.

6. Rename Format.1 by entering the name you wish.

7. You can display the directories used for your assembly by clicking the Search order option. For more about the Search order capability, please refer to Defining a Search Order.

8. Now, choose the properties you wish to display in the Bill of Material section of the Bill of Material dialog box. To do so, for example, select Source from the list Hidden properties and click the show properties icon to move Source into the Displayed properties section.

Likewise, double-clicking a property moves this property into the section opposite.
9. Repeat the operation by adding Description to the Displayed properties section of the Properties for the Recapitulation frame.

The buttons you can use are the following:
- Moves the selected property to the right scroll list
- Moves all properties to the right scroll list
- Moves the selected property to the left scroll list
- Moves all properties to the left scroll list
- Moves the selected property within the scroll list

10. Click OK to validate the creation of the new format.

The Bill of material: Display formats dialog box is closed.

You cannot save the formats you create. Customized formats are specific to your CATIA session.

The Bill of Material now looks like this:

![Bill of Material image]

11. Click the Listing Report tab.

It displays the tree of the product using indents, just like in the application.
12. Check the Search order option if you wish to display the directories implied in the assembly.

13. To display other information in your report, select the properties of your choice in the Hidden properties scroll list and use the buttons as previously described to move these properties to the left.

14. To see the result, click Refresh.

15. Use the Save As... capability to save the report in the directory of your choice. Only .txt format is available.

16. Click OK in the Bill of Material dialog box to exit.
Analyzing Constraints

This task shows you how to analyze the constraints of an active component.

Open the AnalyzingAssembly02.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select Analyze -> Constraints.

The Constraints tab displays the status of the constraints of a selected component:

- **Active Component** displays the name of the active component.
- **Component** displays the number of child components contained in the active component.
- **Not constrained** displays the number of child components not constrained in the active component.
- **Status** displays the status of the constraints:
  - **Verified** displays the number of verified constraints
  - **Impossible** displays the number of impossible constraints.
    "Impossible" means that the geometry is not compatible with the constraint. For example, a contact constraint between two cylinders which diameter is different is impossible. The yellow unresolved symbol is displayed in the specification tree on the constraint type icon: 📌.
  - **Not updated** displays the number of constraints to be updated.
    The application has integrated new specifications, which affect constraints. The update symbol is displayed in the specification tree on the constraint type icon: 🔄.
  - **Broken** displays the number of broken constraints. A reference element is missing in the definition of these constraints. It may have been deleted for example. You can then reconnect this constraint (see Reconnecting Constraints). The yellow unresolved symbol is displayed in the specification tree on the constraint type icon: 📌.
**Deactivated** displays the number of deactivated constraints (see Deactivating or Activating Constraints). The deactivated symbol is displayed in the specification tree. It precedes the constraint type icon: ( ).

**Measure Mode** displays the number of constraints in measure mode.

**Total** displays the total number of constraints of the active component.

Five additional tabs may be displayed if one of these constraint status exist:

- Impossible.
- Not updated.
- Broken.
- Deactivated.
- Measure Mode.

The constraints are then clearly identified in these tabs and you can directly select them. Once selected, they are highlighted in the geometry area.
To redefine the colors of the different type of constraints, see Setting the Constraint Options.

2. Click OK to exit.

This capability does not show overconstrained systems. To see them, remember that the application detects them when performing update operations. You can also use the new command Analyze -> Dependence.
Analyzing Dependencies

This task shows you how to see the relationships between components by using a graph.

Open the AnalyzingAssembly03.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select the component of interest, that is CRIC_BRANCH_3.1

You can analyze the dependencies of your assembly by selecting the root of the tree too.

2. Select Analyze -> Dependency....

The following graph appears, displaying the constraints and components related to the component you have selected.
You can notice that four constraints are set on CRIC_BRANCH_3.1.

- a coincidence constraint between CRIC_BRANCH_3.1. and CRIC_FRAME_.1. that is attached.
- a surface contact constraint between CRIC_BRANCH_3.1. and CRIC_BRANCH_1.1. that is also used for other constraints (Coincidence.8 and Surface contact.9)
- a surface contact constraint between CRIC_BRANCH_3.1. and CRIC_FRAME_1.1.
- a coincidence constraint between CRIC_BRANCH_3.1. and CRIC_BRANCH_1.1.

3. Checking the different options available in the Elements frame, you can display the following:
   - Constraints: by default, this option is activated.
   - Associativity: shows components edited in Assembly Design context. Contextual components are linked to support components by green lines in the graph, as illustrated in the example below:
     CRIC_AXIS.1 has been designed in Assembly Design context. Its geometry lies on CRIC_BRANCH_1.1 and CRIC_BRANCH_3.1
   - Relations: shows formulas. For more information, please refer to CATIA-Knowledge Advisor User's Guide Version 5

4. You can also display the relationships by filtering the components you wish to see: either you check the Child option to take the children of the component into account or check Leaf to hide them.
5. Contextual commands are available:
   - Expand all: lets you see the whole relationships. Note that double-clicking produces the same result.
   - Show children: displays all children of the component
   - Set as new root: sets the selected component as the component which relationships are to be examined

Zooming in and zooming out progressively in the graph is allowed.

6. Click OK to close the graph.
Measuring Components

This task explains how to measure distances and angles between geometrical entities (surfaces, edges, vertices and entire products) or between points.

To get the most out of this tool, set the Render Style icon to (Shading with Edges) or set View -> Render Style -> Shading with Edges.

1. Click the Measure Between icon.

The Measure Between dialog box is displayed.

2. Set the desired measure type in the Measure type drop-down list box

**Defining measure types:**
- Between (default type): measures distance and angle between defined reference and target items
- Chain: sets the target item as the reference item for the next measure
- Fan: fixes the reference item selection so that you always measure from this item

3. Set the desired measure mode in the Target and Reference drop-down list boxes
Defining measure modes:

- **Any geometry** (default mode): measures distances and angles between defined geometrical entities (points, edges, surfaces, etc.)
- **Any geometry, infinite**: measures distances and angles between planar faces mapped onto infinite planes and straight line segments mapped onto infinite lines. For all other selections, the measure mode is the same as any geometry.
- **Point on geometry**: measures distances and angles between points selected on defined geometrical entities.
- **Point only, Edge only, Surface only**: measures distances and angles between points, edges and surfaces respectively. Dynamic highlighting is limited to points, edges or surfaces and is thus simplified compared to the Any geometry mode.
- **Intersection**: measures distances and angles between intersection points between two edges or an edge and a surface. In this case, two selections are necessary to define target and reference items.
- **Edge limits**: measures distances and angles between endpoints or midpoints of edges. Endpoints only are proposed on curved surfaces.
- **Arc center**: measures distances and angles between the centers of arcs.
- **Coordinate**: measures distances and angles between coordinates entered for target and/or reference items.

4. Click to select a surface, edge or vertex.

The appearance of the cursor has changed to reflect the measure command you are in.

A number (1 for the reference item and 2 for the target item) also helps you identify where you are in your measure.

Dynamic highlighting as you move your cursor over surfaces, faces and vertices helps you locate the reference and target items.

5. Click to select another surface, edge or vertex.

A line representing the minimum distance vector is drawn between the selected items in the geometry area. Appropriate distance values are displayed in the dialog box.
The overall minimum distance as well as distance vector components between the selected items and x,y,z coordinates of points between which the minimum distance was measured are given in the Measure Between dialog box.

The number of decimal places is controlled by the DMU Navigator tab in the Options dialog box. See Setting Measurement Display.

6. If necessary, adjust the presentation of the measure. You can move the lines and text of the measure

7. Select another reference item

8. Set the Measure type to Fan to fix the reference item selection so that you can always measure from this item

9. Select the target item

10. Select another target item
Customizing Your Measure:

You can, at any time, customize the display of the results in both the geometry area and the dialog box. To do so, click Customize... in the Measure Between dialog box and set your display in the Measure Between Customization dialog box. By default, all results are displayed.

11. Click Close.
Measuring Edges of Components

This task explains how to measure the properties associated to a selected item (points, edges and surfaces).

1. Set the Render Style icon to (Shading with Edges) or set View -> Render Style -> Shading with Edges.

You cannot use this command, if Shading only is selected.

2. Click to select the desired item.

3. Click the Measure Edge icon .

The appearance of the cursor has changed to reflect the measure command you are in:

Dynamic highlighting as you move your cursor over objects helps you locate the reference item.

The dialog box is updated.

The dialog box gives information about the selected item, in our case a surface. The center of gravity of the surface is visualized by a point. In the case of non planar surfaces, the center of gravity is attached to the surface over the minimum distance.
4. Click Customize... in the Measure Item dialog box to see the properties the system detects for the various types of item you can select.

![Measure Item Customization](image)

**Customizing Your Measure:**
You can, at any time, customize the display of the results in both the geometry area and the dialog box. To do so, click Customize... in the Measure Item dialog box and set your display in the Measure Item Customization dialog box. By default, all results are displayed.

6. Try selecting other items to measure associated properties

The system detects whether the edge is a line, curve or arc, taking model accuracy into account. If a line or curve is detected, the dialog box indicates the length as well as X, Y, Z coordinates of the start and end points. If an arc is detected, the dialog box also indicates the arc angle, radius or diameter and the X, Y, Z coordinates of the center point.

7. If necessary, adjust the presentation of the measure:

You can move the lines and text of the measure

The number of decimal places is controlled by the DMU Navigator tab in the Options dialog box. See [Setting Measurement Display](#).
8. Click Close when done.
Moving Components

This section describes the different ways of moving a component. The Assembly workbench allows you to translate, rotate, snap and manipulate components.
Translating Components

This task will show you two ways of translating a component:
- by entering translation values
- by selecting geometrical elements to define a translation direction.

The component to be translated must belong to the active component.

Open the MovingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Translate or Rotation icon.

The Move dialog box is displayed.

Either you specify an offset value between the element and according to x, y or z axis, or you select a geometric element to define the direction you need.
2. Select the component to be translated, that is CRIC_BRANCH_3.

3. Enter 50 mm as the offset value, in the Offset X field.
4. Click Apply.

The selected component is translated accordingly.

5. Click the Invert button to reverse the previous operation and translate the component in the opposite direction.

The translation is reversed.

You can click Apply as many times as you wish to translate the component onto the desired position.
6. Click OK to close the dialog box.

7. Repeat steps 1 and 2.

8. Now, click the Selection button to define a new translation with respect to a geometrical element.

The Translation tab contents is grayed.

If you select a line or a plane you need to enter a distance value. The translation is then done along the selected line or normal to the selected plane. Selecting two faces or plane assumes these elements are parallel.

9. Select the red and blue faces as shown.

These faces are parallel.
CATIA computes the distance between these faces. The Offset field then displays this distance value:

- Offset X: 20mm
- Offset Y: 0mm
- Offset Z: 0mm

10. Click Apply to translate the blue component.

You can apply this translation to any other components. You just need to select it and click the Apply button.

11. Click OK to exit.

Using Shift key and the compass lets you translate constrained components.
Rotating Components

This task will show you the two ways of rotating a component:

- by entering the rotation angle and specifying the rotation axis
- by selecting a geometric element as the rotation axis and entering the angle value.

The component to be rotated must belong to the active component.

Open the MovingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Translate or Rotation icon.

The Move dialog box is displayed. Translation options are available. To know how to translate components, refer to Translating a Component.

2. Click the Rotation tab.

3. Select the component to be rotated, that is CRIC_BRANCH_1.

4. Check the Axis Y option.

5. Enter 90 as the angle value in the Angle field.

6. Click Apply.

The selected component is rotated accordingly.

7. Click OK to close the dialog box.
8. Repeat steps 1 and 2.

9. Now, click the Selection button to define a new rotation with respect to a geometrical element.

10. Select the edge as shown to specify the new rotation axis.

11. Enter 90deg in the Angle field.

12. Click Apply to rotate the red component.

You can apply this rotation to any other components. You just need to select it and click the Apply button.

13. Click OK to exit.

Using Shift key and the compass lets you rotate constrained components.
Manipulating Components

The Manipulate command lets you move a component freehand with the mouse. It is less constraining than the Translate and Rotate commands.

This task will show you how to manipulate a component. The component to be manipulated must belong to the active component.

Open the ManagingComponents02.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Manipulate icon . This command is also available from the Edit menu.

The Manipulation Parameters dialog box appears:
- The first and second horizontal lines are reserved for translations.
- The third line is reserved for rotations.
- The fourth column lets you define the direction of your choice by selecting a geometric element.

2. Click the Drag along Y axis icon .
3. Select Set1 as the component to be translated.

The component is translated in the Y axis direction.

5. Now select CRIC_FRAME and click Drag around Y axis icon.
6. Drag the component. You are rotating it around the Y axis.

7. Check the option With respect to constraints. If you repeat the previous operation, you will notice that you are not allowed to do it. The existing parallelism constraint prevents you from moving the component.

8. Click OK to exit.

Using Shift key and the compass lets you manipulate constrained components.
The Snap command allows you to project the geometric element of a component onto another geometric element belonging to the same or to a distinct component.

The element to be snapped must belong to the active component.

Open the MovingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

Depending on the selected elements, you will obtain different results. This table indicates what you can do:

<table>
<thead>
<tr>
<th>First Element Selected</th>
<th>Last Element Selected</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>point</td>
<td>point</td>
<td>Identical points.</td>
</tr>
<tr>
<td>point</td>
<td>line</td>
<td>The point is projected onto the line.</td>
</tr>
<tr>
<td>point</td>
<td>plane</td>
<td>The point is projected onto the plane.</td>
</tr>
<tr>
<td>line</td>
<td>point</td>
<td>The line passes through the point.</td>
</tr>
<tr>
<td>line</td>
<td>line</td>
<td>Both lines become collinear.</td>
</tr>
<tr>
<td>line</td>
<td>plane</td>
<td>The line is projected onto the plane.</td>
</tr>
<tr>
<td>plane</td>
<td>point</td>
<td>The plane passes through the point.</td>
</tr>
<tr>
<td>plane</td>
<td>line</td>
<td>The plane passes through the line.</td>
</tr>
<tr>
<td>plane</td>
<td>plane</td>
<td>Both planes become parallel.</td>
</tr>
</tbody>
</table>

1. Click the Snap icon.
2. Select the red face as shown.

The element selected first is always the element that will move.
3. Select the blue face as shown.

The red face is projected onto the plane defined by the blue face.
Exploding the View of an Assembly

Exploding the view of an assembly means separating the components of this assembly to see their relationships. Exploded views can be used in a drawing view.

This task shows you how to explode the view of an assembly. The application lets you explode either the whole assembly or its sub-assemblies.

Moreover, you can explode the selected assembly or sub-assembly in:

- **3D**
- In a **Projection** plane normal to the screen.

Open the ManagingComponents02.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click the Explode icon \(
\begin{array}{c}
\text{Explode icon} \\
\end{array}
\) . This command is also available from the Edit -> Move menu. The Explode dialog box is displayed.

2. Select the sub-assembly to be exploded, that is Set1.
3. Set the Depth option to First level to specify you need the sub-assembly only.

4. Click Apply to compute the exploded view.

The Scroll Explode field gradually displays the progression of the operation. The application assigns directions and distance.

Only the sub-assembly is exploded.

5. Now select the whole assembly and set the Depth option to All levels.

6. Click Apply to compute the view. Once the ratio has reached 2.00, the exploded view looks like this:
7. Click the left arrow to set the ratio to 1.
The number to the right of the slider in the Scroll Explode section depends on the different levels defining the selected assembly. The Left and Right arrows allow you to move to the root of each component level. Dragging the slider from the right to the left reduces the separation between components. Conversely, dragging the slider from the left to the right increases this separation.

5. Click OK to keep the product exploded.

The constraints contained in the product may need an update after the operation.
Using Assembly Tools

This section illustrates the tools available in the Assembly Design workbench.
Defining a Search Order

This task will show you how to create a personal search priority for your documents.

The Search Order command defines the priorities for the paths where you will find the components of an assembly when you open it.

Open the AssemblyTools01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Select Tools -> Search Order.

The Search Order dialog box is displayed.
It displays:

- **Directory**: the current directory, click the Refresh to refresh it.
- **Subdirectories**: the directories contained in the directory.
- **Selection**: the directory to be selected, click Add to add it in the search order list.
- **Delete**: deletes the selected directory in the search order list.
- **Move**: moves the selected directory in the search order list.
- **Save search order**: saves the current search order list.
- **Load search order**: loads the current search order list.

2. In the Directory field, enter the complete path to reach SAMPLES/AssemblyDesign/SearchOrder directory, or if necessary navigate in Subdirectories.

3. Click Add.

4. Select Search order directories first and restart CATIA.

5. Open the AssemblyTools01.CATProduct document from the SAMPLES/AssemblyDesign directory.

The document uses the component contained in SAMPLES/AssemblyDesign/SearchOrder directory.
So, when you open an assembly or import a component, this path will be the first to be browsed. Make sure the Search Order searches for the name of the documents only. You can define as many paths as you want and rearrange these paths with the Delete or Move buttons.
Managing Products in an Assembly

This task consists in managing products in an assembly.

Open the AssemblyTools01.CATProduct document from the online\samples\AssemblyDesign directory.

1. Select Tools -> Product Management...

The Product Management dialog box is displayed.

You can see for each components contained in the assembly:

- **The Part Number**.
- **The Document** source file.
- **The Status** of the component.
- The associated **Representation**.

You can modify the part number in the New part number field and replace the associated representation in the New representation field of the selected product.

2. Click the ... button to open the Replace Representation dialog box.

3. Click OK to valid, Cancel to abort.
Managing a Product Publication

The interest of the Product Publication command lies in the capability of automatically reconnecting constraints.

Published elements are actually provided with specific names. If constraints are defined for these elements, if you then substitute these elements for other published elements (see Replacing a Component), the application automatically reconnects the constraints.

The Management Publication command allows you to manage the publication of geometrical elements contained in the child components of the active component.

You can:

- **Add** a publication **Name** to a geometric element.
- **Delete** a publication.
- **Modify** the geometric element associate to a Name.

This task shows you how to manage the products publication.

Open the AssemblyTools01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Set CRIC_JOIN (CRIC_JOIN.1) as active component to be published.

2. Select Tools -> Publication Management...

The Publication Management dialog box appears.

It displays:

- The **Name** of the published geometrical elements in the product.
- The publication **Status**.
- The **Path** between the publication name and the geometrical element.
3. Click Add in the Publication Management dialog box.

The Publication Definitions dialog box is displayed.

It displays:

- **Name**: the name of the published element.
- **Published Element**: if the geometrical elements to be published is selected or not.
- **Internal Publications**: the list of the published elements contain only in its primary child components.
- **Element Access**: check the access to the published element.
4. Select the axis of CRIC_JOIN (CRIC_JOIN.1) to be published and define its name: Axis_Join. (To select the axis, we recommend the use of the Zoom capability).

5. Click OK.

The publication is added in the Publication Management dialog box and the Publication branch is added below CRIC_JOIN (CRIC_JOIN.1).
6. Select the publication in the Publication Management dialog box and click Modify. The Publication Definitions dialog box is displayed.

You can only change the geometrical element associated to the publication name, not the name.

7. Click Cancel.

8. Click Close.

9. Set Set1 (Set1.1) as the active component to be published.

10. Select Tools -> Publication Management...

11. Click Add in the Publication Management dialog box.

The Publication Definitions dialog box is displayed.

It displays the internal publication of Set1 (Set1.1) contained in CRIC_JOIN (CRIC_JOIN.1): Axis_Join.
12. Select this internal publication and define its name: Axis_Join_Set1.

The publication is added in the Publication Management dialog box and the Publication branch is added below Set1 (Set1.1).
13. Click Close.
**Advanced Tasks**

*CATIA - Assembly Design* allows you to do the following advanced tasks:

- You will learn how to reconnect:
  - Components and their constraints when replacing a representation
  - Existing constraints
- You will use functions available in other workbenches:
  - Edit a CATPart in an assembly and take its modifications into account
  - Use *Digital Mock-Up (DMU) Navigator* functions
Reconnecting a Replaced Representation

This task consists in reconnecting a replaced representation.

1. Right-click in the Specifications Tree on Cube(Cube1).

2. Then select Representation -> Replace from the contextual menu.

   This command is also available from the Edit menu.

   The Replace Representation dialog box is displayed.

3. Select the CUBE2.model document from the samples/assembly_design directory.
4. Click Open.

   The Reconnect Representation dialog box is displayed.

   You will find in this dialog box:

   - a window containing the assembly with the old representation
   - a window containing only the new representation where you reconnected the geometric element
   - a table containing the list of the geometric elements of the old representation to be reconnecte

   The first geometric element of the list is pre-selected in the table and in the assembly with the old representation.

   You can reconnect the geometric elements in the order of your choice.
5. Select to reconnect the highlighted geometric element of the old representation a geometric element on the new representation.

The geometric element is reconnected. The next geometric element to be reconnected is pre-selected.

In this task, we do not reconnect the second geometric element. All the geometric elements which are not reconnected will be lost.

6. Click OK to validate.

The representation is replaced.

The Coincidence constraint is broken. To know how to reconnect constraints, see Reconnecting Constraints.
Reconnecting constraints means defining new supporting elements for these constraints. You will perform this operation for correcting mistakes you made while assembling components or for correcting the mistakes detected by updates.

This task shows you how to reconnect two constraints.

Open the AssemblyConstraint06.CATProduct document from the \online\samples\AssemblyDesign directory.

1. The assembly contains a contact and a coincidence constraint that need to be reconnected. Double-click the contact constraint to be reconnected.

2. In the Constraint Edition dialog box that appears, click More to access additional information. The names of supporting elements are now displayed.

3. Click CRIC_BRANCH_3 then Reconnect.

4. Select the blue face as shown to specify the new supporting face.
5. Click OK.

The contact constraint is reconnected:

6. Now select the coincidence constraint in the geometry or in the specification tree.

7. Select the Properties contextual command.

8. In the Properties dialog box that appears, click CRIC_BRANCH_3.
9. Click Reconnect.

The window that appears displays the components.
10. Select the axis passing through the circular faces.

11. Click OK to close the window.

12. Click OK to close the Properties dialog box.
Editing a Part in an Assembly Design Context

This task shows you how to edit a CATPart in *CATIA - Assembly Design* context.

Open the ManagingComponents01.CATProduct document from the \online\samples\AssemblyDesign directory.

1. Click on the + sign preceding the CRIC_SCREW component in the tree. The Product document is identified with the Product document icon.

2. Double-click on the part CRIC_SCREW to open the *CATIA - Part Design* workbench.

   Do not mistake the Product document for the Part Design document:

   ![Diagram](image)

   The Part Design document is identified with the Part Design document icon.

   The *CATIA - Part Design* workbench is displayed.

3. Click on the + sign to the left of Part Body.

4. Double-click the feature you need to edit. For example, double-click on Pad2 to display the Pad Definition dialog box. You can then enter the parameters of your choice.

5. Once you have edited the part, to return into the CATIA-Assembly Design workbench, double-click on ManagingComponents01.

The CATIA-Assembly Design workbench is then displayed and a green wheel is added to the component in the tree to represent the contextual nature of the component. Note however that this symbol displays only if the option Keep link with selected object is on. For information, please refer to CATIA-Part Design User's Guide Version 5.

Contextual components are considered as the children of the components used for their creation. This means that if you delete these support components, you will need to consider if you wish to delete contextual components or not. Remember, you can choose to delete affected elements by checking the Delete all children option of the Delete dialog box.
Workbench Description

The CATIA - Assembly Design Version 5 application window looks like this:

Click the sensitive areas to see the related documentation.
Assembly Design Menu Bar

This section presents the main menu bar available when you run the application and before creating or opening a document:

Start  File  Edit  View  Insert  Tools  Analyze  Windows  Help

File

For  See

New  Creating a New Assembly Document
Open  Opening an Existing Assembly Document
Save  Saving an Existing Assembly Document
Save As  Saving an Assembly Document As
Edit

For

Delete
Component Constraints
Properties
Update
Move
Representation
Load
Unload
Design Mode
Visualization Mode
Replacement Component...

See
Modifying the Properties of a Component
Using Assembly Constraints
Modifying the Properties of a Constraint
Updating Assembly Constraints
Moving the Components
Managing Representations
Unloading or loading Components
Unloading or Loading Components
Using Design Mode Functionality
Using Visualization Mode Functionality
<table>
<thead>
<tr>
<th>Insert Menu</th>
<th>For</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Coincidence</td>
<td></td>
<td>Creating a Coincidence Constraint</td>
</tr>
<tr>
<td>Contact</td>
<td></td>
<td>Creating a Contact Constraint</td>
</tr>
<tr>
<td>Offset</td>
<td></td>
<td>Creating an Offset Constraint</td>
</tr>
<tr>
<td>Angle</td>
<td></td>
<td>Creating an Angle Constraint</td>
</tr>
<tr>
<td>Fix Together</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fix</td>
<td></td>
<td>Fixing a Component</td>
</tr>
<tr>
<td>Auto Constraints</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New Component</td>
<td></td>
<td>Inserting a New Component</td>
</tr>
<tr>
<td>New CDM Component</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New Part</td>
<td></td>
<td>Inserting a New Part</td>
</tr>
<tr>
<td>Existing Component</td>
<td></td>
<td>Inserting an Existing Component</td>
</tr>
</tbody>
</table>
Tools

- Options...
- Search Order...
- Product Management...
- Publication Management

See
- Setting the Assembly Design Options
- Creating a Personal Search Route
- Managing Products in an Assembly
- Managing a Product Publication

Analyze

- Compute Clash...
- Bill of Material...
- Constraints...
- Measure Between...
- Measure Edge...

See
- Computing Clash between Components
- Displaying the Bill of Material
- Analyzing the Constraints
- Measuring Components
- Measuring Edges of Components
Product Structure Tools Toolbar

See Inserting a New Component

See Inserting a New Part

See Inserting an Existing Component

See Managing Representations

See Replacing a Component

See Fast Multi-Instantiation

See Defining a Multi-Instantiation
Move Toolbar

See Translating or Rotating a Component
See Manipulating a Component
See Snapping a Component
See Exploding an Assembly
See [Creating a Coincidence Constraint](#)

See [Creating a Contact Constraint](#)

See [Creating an Offset Constraint](#)

See [Creating an Angle Constraint](#)

See [Fixing a Component](#)

See [Fixing Components Together](#)

See [Using the Autoconstraint Mode](#)

See [Deactivating or Activating Constraints](#)

See [Changing Constraints](#)

See [Using a Pattern](#)
Measure Toolbar

See Measuring Components

See Measuring Edges of Components
Update Toolbar

See Updating Assembly Constraints
Customizing

This section describes the different types of setting customization you can perform in your assembly structure using the Tools -> Options command. All tasks described here deal with permanent setting customization.

<table>
<thead>
<tr>
<th>Setting the Update of Constraints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting the Constraint Appearance</td>
</tr>
<tr>
<td>Setting the Paste Component Behavior</td>
</tr>
<tr>
<td>Displaying the Bounding Box</td>
</tr>
<tr>
<td>Setting the Constraint Creation</td>
</tr>
<tr>
<td>Setting Warning Display</td>
</tr>
<tr>
<td>Setting the Autoconstraint Command</td>
</tr>
<tr>
<td>Using the Cache Memory</td>
</tr>
<tr>
<td>Setting Measurement Display</td>
</tr>
<tr>
<td>Defining the Default Part Number</td>
</tr>
<tr>
<td>Setting the Representation</td>
</tr>
<tr>
<td>Setting the Specification Tree</td>
</tr>
</tbody>
</table>
## Glossary

### A

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>active component</td>
<td>A selected <a href="#">component</a> currently being edited. This component is underlined in the specification tree.</td>
</tr>
<tr>
<td>active object</td>
<td>An object currently being edited.</td>
</tr>
<tr>
<td>angle constraint</td>
<td>A <a href="#">constraint</a> used to define an angle or parallelism between two geometric elements.</td>
</tr>
<tr>
<td>assembly</td>
<td>An entity composed of various <a href="#">components</a> which have been positioned relative to each other.</td>
</tr>
</tbody>
</table>

### B

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>bill of material</td>
<td>A list of data about the properties of the <a href="#">components</a> contained in the <a href="#">active component</a>.</td>
</tr>
</tbody>
</table>

### C

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>child component</td>
<td>One or more <a href="#">components</a> originating from a single component. Compare <a href="#">parent component</a>.</td>
</tr>
<tr>
<td>coincidence constraint</td>
<td>A <a href="#">constraint</a> used to align two geometric elements, or get them to coincide.</td>
</tr>
<tr>
<td>component</td>
<td>A reference integrated in an <a href="#">assembly</a>. A component possesses characteristics related to how it is integrated in an assembly (for example, its relative location in an assembly).</td>
</tr>
<tr>
<td>constraint</td>
<td>A geometrical or dimensional relation between several <a href="#">geometric elements</a> of different <a href="#">components</a>. It may be used to define the positioning of components.</td>
</tr>
<tr>
<td>context-specific representation</td>
<td>A hierarchical design of an <a href="#">assembly</a> in a specific context (for example: engineering or manufacturing).</td>
</tr>
<tr>
<td>contact constraint</td>
<td>A <a href="#">constraint</a> used to define a contact area between two elements (tangent or coincident).</td>
</tr>
</tbody>
</table>
**F**

**fixed component**  A component for which all degrees of freedom are locked, in relation to the parent component.

**G**

**geometric element**  The geometric elements which can be constrained in Assembly workbench are:
- point
- line
- plane (or plane surface from a model)
- sphere
- cone
- cylinder

**L**

**leaf component**  The last component at the end of each branch of the specification tree.

**M**

**manipulation**  A freehand translation or rotation of a component with the mouse.

**model**  A CATIA Version 4 model.

**O**

**offset constraint**  A constraint used to define a distance or an offset between two geometric elements.

**P**

**parent component**  A component that is hierarchically just above one or more components. Compare child component.
part

Within the Assembly workbench, it is either a part of the Part Design workbench, or a 3D entity whose geometry is contained in a model.

primary child component

One or more components originating from the first level under the active component.

product

A 3D entity which contains several components.

reference

A product or part with its own characteristics. Compare component.

representation

See context specific representation.

search order

A hierarchical set of paths used when searching for the files included in the assembly. The search begins with the first path, and stops when the file is found.

snap

Projects a geometric element onto another one.

subassembly

An assembly contained within another assembly.

update

In the Assembly workbench, updates the position of the constrained components so as to satisfy the constraint requirements.