CATIA Version 5 Interactive Drafting is a new generation CATIA product that addresses 2D design and drawing production requirements.

CATIA Interactive Drafting is a highly productive, intuitive drafting system that can be used in a standalone 2D CAD environment within a CATIA backbone system. It also expands the CATIA Generative Drafting product with both integrated 2D interactive functionality and an advanced production environment for the dressup and annotation of drawings. This provides an easy and smooth evolution from 2D to 3D-based design methodologies.

Complementing an existing CATIA Version 4 installation, Interactive Drafting benefits from upward compatibility with Version 4, making it possible to browse or complete in Version 5 drawings started with Version 4.

The CATIA - Interactive Drafting User's Guide has been designed to show you how to create drawings from various complexities. There are several ways of creating a drawing and this documentation aims at illustrating the several stages of creation you may encounter.
Using This Documentation

This User’s Guide is intended for a draftman who needs to become quickly familiar with CATIA-Interactive Drafting Version 5 product. Before reading it, the user should be familiar with basic CATIA Version 5 concepts such as document windows, standard and view toolbars.

To get the most out of this guide, we suggest that you start reading and performing the step-by-step tutorial Getting Started and the Workbench Description to find your way around the Drafting.

To get the most out of this guide, we suggest you start reading and performing the step-by-step tutorial Getting Started. This tutorial will show you how to create a basic drawing from scratch.

The next sections deal with the handling of drawing, then the creation and modification of various types of features you will need to obtain a complex drawing. This guide also presents other InteractiveDesign capabilities allowing you to design complex parts. You may also want to take a look at the sections describing the Interactive Drafting menus and toolbars at the end of the guide.
Where to Find More Information

Prior to reading this book, we recommend that you read the **CATIA- Infrastructure User's Guide Version 5** that describes generic capabilities common to all **CATIA Version 5 products**. It also describes the general layout of CATIA V5, and interoperability between workbenches. Also read the **CATIA V4 Integration documentation** that presents interfaces with standard exchange formats and most of all with CATIA V4 data.

# What's New

## Manipulating the Drafting Sheet
- **New:** [Creating a Detail Sheet](#)
- **New:** [Creating Dittos on a Sheet](#)

## Manipulating Dimensions
- **Enhanced:** [Choosing the Angle Dimensions](#)
- **Enhanced:** [Lining up Dimensions](#)

## Using Constraints
- **Enhancement:** [Creating Constraints via Autodetection](#)
- **Enhancement:** [Creating Geometric Constraints](#)
- **Enhancement:** [Creating Dimensional Constraints](#)

## Manipulating Annotations
- **Enhanced:** [Adding a Leader to Existing Text](#)
- **Enhanced:** [Painting Existing Elements](#)
- **Enhanced:** [Creating a Welding Symbol](#)
- **Enhanced:** [Creating a Geometry Weld](#)
Getting Started

Before getting into the detailed instructions for using Interactive Drafting workbench, the following tutorial aims at giving you a feel of what you can do with the product. It provides a step-by-step scenario showing you how to use key functionalities. The main tasks described in this section are:

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entering the Workbench</td>
</tr>
<tr>
<td>Creating a New View</td>
</tr>
<tr>
<td>Creating Rectangles</td>
</tr>
<tr>
<td>Creating Corners</td>
</tr>
<tr>
<td>Creating Lines</td>
</tr>
<tr>
<td>Translating Lines</td>
</tr>
<tr>
<td>Creating Circles</td>
</tr>
<tr>
<td>Translating Circles</td>
</tr>
<tr>
<td>Creating Dimensions</td>
</tr>
<tr>
<td>Creating Annotations</td>
</tr>
</tbody>
</table>

This step-by-step scenario introduces the basic capabilities of Interactive Drafting. You just need to follow the instructions as you progress along.

Before discovering this scenario, you should be familiar with the basic commands common to all workbenches. These are described in the Basics User's Guide.

All together, the tasks should take about 30 minutes to complete.

The final drawing will look like this:
Entering the Interactive Drafting Workbench

This first task shows you how to enter the Drafting workbench and start a new drawing.

1. Select the File -> New commands (or click the New icon).
The New dialog box is displayed, allowing you choosing the type of the document you need.

2. Select Drawing in the List of Types field and click OK.

The New Drawing dialog box is displayed, allowing you choosing the type of Standard, Format and orientation you need.

3. Select the ANSI standard and click the Landscape option.

4. Click OK.

The Drafting workbench is loaded and an empty Drawing sheet opens:
5. Make sure you customized the unit accordingly. For this:
   a. Select the Tools -> Options command to display the Options dialog box.
   b. Click General in the list of objects to the left of the Options dialog box.
   c. Select the Units tab and set Length to Inch and then click OK.

To visualize better your drawing, tile the windows horizontally from the menu bar.

The commands for creating and editing features are available in the workbench toolbar. Now to fully discover the Interactive Drafting workbench, let's perform the following tasks.
Creating a New View

In this task you will learn how to create a new view in the empty drawing you just opened using the Drafting Interactive workbench. Afterwards, you will draw geometry in this empty view.

1. Click the New View icon and click the Drawing sheet.

In the following tasks, you will learn how to draw geometry in the empty view displayed which is by default a front view.
Creating a Rectangle

This task shows you how to define geometry in the newly created empty view which is by default, the front view. In this particular case, let’s create a rectangle from coordinates 0,0 to coordinates 3.5,2.5 (inches).

1. Click the Rectangle icon  from the Geometry creation toolbar (Profiles subtoolbar).

The Tools toolbar displays two value fields: horizontal value (H) and vertical value (V).

2. Enter the First Point coordinates. For example, H: 0in and V: 0in.
3. Press Enter.

4. Enter the Second Point coordinates. For example, H: 3.5in and V: 2.5in.
5. Press Enter to end the rectangle creation.

The rectangle appears in the empty view.

You can also move the cursor for directly positioning the second point. The corresponding values similarly appear on the Tools toolbar.
Creating Corners

This task shows you how to create corners on an existing rectangle by multiselecting points.

1. Multiselect the rectangle endpoints.

2. Click the Corner icon from the Geometry edition toolbar (Relimitations subtoolbar).

   The Tools toolbar displays with a Radius field:

   ![Tools toolbar with Radius field]

3. Enter a radius value in the Tools toolbar. For example, Radius: 0.25in.

4. The four corners are automatically created with the same radius value.

You can also select the Corner icon first and then click the geometry for creating the corners one after the others.
Creating Lines

In this task you will learn how to create a line.

1. Click the Line icon from the Geometry creation toolbar.

The Tools toolbar displays First Point value fields:

```
First Point : H: 1.625in  V: 0in
```

2. Enter the line First Point coordinates. For example, H: 1.625in and V: 0in.

3. Press Enter.

4. Drag the cursor to the desired location for creating the second line point. For example, drag the line end point to the top rectangle horizontal line.

In this particular case, autodetection is used for creating the line. In other words, you want the line to be parallel with one of the rectangle lines.
Translating Lines

This task shows you how to create additional lines from an existing one.

1. Select the line to be translated.

2. Click the Translate icon from the Geometry edition toolbar (Transformations subtoolbar).

The Translation Definition dialog box appears and the Start Point value fields (H and V) display from the Tools toolbar.

3. The Duplicate mode option (Translation Definition dialog box) is activated, by default. If needed, activate this mode.

4. Enter the duplicated line Start Point coordinates in the Tools toolbar. For example, H: 1.625in and 2.5in.

5. Press Enter.

6. Enter the duplicated line End Point coordinates in the Tools toolbar. For example, H: 1.625in and 0in.

7. Press Enter.

8. Enter the line Length Value in the Translation Definition dialog box. For example, 2.5in.

The Snap Mode is automatically deactivated.

9. Click OK to validate.

10. Once you are satisfied with your operation, click inside the view. The second line is created.
Proceed in the same manner to create the third, fourth, fifth and sixth lines. The process described above is valid for any other line to be created with the Translation command in our context.

Select two lines at a time to perform your translation, it is time-saving.

Your final drawing will look like this:

You can also select the Translate icon first and then the geometry to be translated.
Creating Circles

This task shows you how to create circles and circle centers using coordinates.

1. Select the Circle icon from the Geometry creation toolbar.

The Tools toolbar displays circle value fields.

2. Enter the Circle Center coordinates. For example, H: 0.75in ans H: 2in.

3. Press Enter.

4. Enter the circle radius. For example, R: 0.375in.

5. Press Enter.

6. Repeat the scenario to create the second circle using the same values.
Now, let's create inner circles. For this:

7. Click again the Circle icon.
8. Select the existing circle center.
9. Enter the center circle radius.
10. Press Enter.

11. Repeat the scenario to create the second inner circle.

This is what you obtain:

You can either select the geometry to be translated first or the Translation command.
Translating Circles

This task shows you how to duplicate existing circles using translation.

1. Select the circles to be translated. Use the multiselection capability.

2. Click the Translate icon from the Geometry edition toolbar.

   The Translation Definition dialog box and the Start Point value fields (Tools toolbar) display.

3. Enter the Start Point coordinates. For example, H: 0in and V: 0in.
4. Enter the End Point coordinates. For example, H: 1.875 and V: 0in.

5. Press Enter.

6. Enter the desired Length value in the Translation Definition dialog box. For example, 1.875in.

   The Snap mode is deactivated.

7. Click OK to confirm your operation.

   This is what you obtain:

   You can either select the geometry to be translated first or the Translate icon.
Creating Dimensions

This task shows you how to add dimensions to the geometry you previously created.

1. Click the dimension icon from the Dimensioning toolbar.

2. Click a first element in the view. For example, the rectangle top line.

3. Click a second element in the view. For example, the rectangle bottom line.

The dimension type is automatically defined according to the selected elements. In this case, you create a distance dimension.
4. If needed, re-position the dimension to the desired location.

Now that you know how to quickly apply dimensions to 2D geometry, create as many as required.
Creating Annotations

This task shows you how to add annotations to existing 2D elements.

1. Click on an icon from the Annotations toolbar. For example, the Text icon.

2. Click an element you want to add an annotation.

3. Enter the required text in the Text Editor dialog box. The text you just entered in the dialog box appears below the annotation in a wysiwyg way.

4. If needed, drag the text to the desired location.

5. Now that you know how to quickly apply annotations to 2D geometry, create as many as required.

The annotation will now remain associated to the selected 2D element. In other words, each time you move the 2D element, the associated annotation moves accordingly.
Up
Creating Rectangles
Translating Lines
Creating Dimensions
Creating Annotations

Entering the Workbench
Creating Corners
Creating Circles

Creating Lines
Translating Circles
Creating a New View
The basic tasks you will perform in the Interactive Drafting workbench are mainly the creation and modification of two-dimensional elements and their related attributes on a predefined sheet.

This section will explain and illustrate how to create various kinds of features to obtain a complete CATDrawing document. The table below lists the information you will find.

<table>
<thead>
<tr>
<th>Theme</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manipulating the Drafting Sheet</td>
</tr>
<tr>
<td>Creating Views</td>
</tr>
<tr>
<td>Creating 2D Geometry</td>
</tr>
<tr>
<td>Editing 2D Elements</td>
</tr>
<tr>
<td>Applying Transformations</td>
</tr>
<tr>
<td>Manipulating Dimensions</td>
</tr>
<tr>
<td>Using Constraints</td>
</tr>
<tr>
<td>Manipulating Annotations</td>
</tr>
<tr>
<td>Manipulating the Dress-Up of a View</td>
</tr>
<tr>
<td>Displaying and Editing Properties</td>
</tr>
<tr>
<td>Printing a CATDrawing Document</td>
</tr>
</tbody>
</table>
Manipulating the Drafting Sheet

The Interactive Drafting workbench provides a simple method to manipulate a sheet. Now, you are going to define and modify the sheet and its background through the creation of a frame title block.
Defining a Sheet

This task will show you how to define a sheet.

1. Click \( \text{File} \rightarrow \text{New} \) commands
2. Select the Drawing workbench, and click OK.
3. Select the Landscape option from the New Drawing dialog box.
4. Click OK.

You can modify at any time the sheet orientation and/or scale. For this, you select the File->Page Setup items from the toolbar.

The sheet size depends on the standard selected. For example, if you choose the ISO standard, the sheet will automatically be assigned the A0 format.
To add a new sheet, click the New Sheet icon. The new sheet automatically appears as follows:

Once you have created more than one sheet, to activate one of the sheets, select this sheet from the dialog window.
Modifying the Sheet

This task will show you how to modify the sheet orientation.

Create a sheet using the Landscape orientation in the New Drawing dialog box.

1. Select the File->Page Setup items from the menu bar.
2. Click OK.

Using this dialog and the Page Setup dialog box, you can also modify the sheet scale which is set to 1, by default.
Deleting a Sheet

This task will show you how to delete a sheet. When a CatDrawing is open, a sheet is necessarily displayed. This is why you can only delete a sheet other than sheet number one.

You created more than one sheet.

1. Select the sheet from the specification tree. For example, Sheet 2.
2. Right-click the selected sheet and display the contextual menu.
2. Select the Delete option from the contextual menu.

Sheet 2 is deleted.
Creating a Frame Title Block

This task shows you how to create a background sheet and insert a frame and a title block.

Open a CATDrawing document.

1. Select the Edit->Background items from the menu bar.

2. Click the Frame Creation icon.

The Insert Frame and Title Block dialog box is displayed.
3. Click OK.

The Insert Frame and Title Block are as follows:
Creating a Detail Sheet

This task will quickly show you how to create a detail sheet. In other words, you are going to create some kind of a intermediary catalog that you will use for positioning dittos on a drawing sheet afterwards.

1. Click the New Detail Sheet icon from the Sheets toolbar.

The newly created detail sheet automatically displays.

For more information on how to customize sheet background colors see CATIA.Generative Drafting user’s guide.
Creating Dittos on a Sheet

This task shows you how to create dittos from a detail previously created on a detail sheet.

Create a detail sheet and enter the drawing sheet in which you want to insert dittos.

1. Click the Instantiate Detail icon.
2. Go to the detail sheet (sheet 2) and select the ditto.

You can select the ditto from the design tree. You can also select a ditto that already exists on the drawing sheet.

The drawing sheet automatically displays (sheet 1).

4. Click to position the ditto.
5. If needed, modify the newly positioned ditto scale and/or angle.
You can modify the ditto via manipulators. You can also modify a group of objects including a ditto.

For positioning several dittos on the sheet, double click the Instantiate Detail icon 🏁.
Creating Views

The Interactive Drafting workbench provides a simple method to create views. This task will show you how to create views. If the sheet is active, the first view you create is by default a front view.

1. Click the New View icon.
2. Click the Drawing window.

A blue axis displays in a red frame. The front view created displays in the specification tree.

3. Click again the New View icon for creating more views. The views created are projection views as they are linked to the front view.

You can create:
- Top views
- Bottom views
- Left views
- Right views

from an active front view.

If you need to switch to the Third angle projection method, specify it via the Sheet Properties option.
4. Activate a projection view by double-clicking the view.

5. Click the New View icon for creating the rear view.

The following table shows the possibilities of view creation according to the active view type.

<table>
<thead>
<tr>
<th>Active View</th>
<th>Resulting Projection Views (linked to the active view)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Front view</td>
<td>Bottom view, Top view, Right view, Left view</td>
</tr>
<tr>
<td>Right view</td>
<td></td>
</tr>
<tr>
<td>Front view</td>
<td></td>
</tr>
<tr>
<td>Left view</td>
<td></td>
</tr>
</tbody>
</table>
Left view
Right view

Rear view
Auxiliary view

Up
Creating 2D Geometry
Manipulating Dimensions
Manipulating the Dress-Up

Manipulating the Drafting Shell
Creating Views
Editing 2D Elements
Using Constraints
Displaying and Editing Proper Printing a CATDrawing Doc.
Creating 2D Geometry

The **Interactive Drafting workbench** provides a simple method for creating and editing two-dimensional geometry. The tools it offers enable you to create and edit geometry, dimension and create relations between 2D elements.

Note also that the Interactive workbench provides **Autodetection** an easy-to-use tool designed to make all your geometry creation as simple as possible.

Before creating 2D geometry, you can double-click the icon and then create as many elements as desired.
This task shows how CATIA can assist you when creating two-dimensional geometry. Multiselection can be also very useful.

The Tools toolbar provides four options:

- **Grid**
- **Snap to Point**
- **Visualize/Create constraints**
- **Differentiating between two-dimensional elements and generated elements from 3D**
- **Value Fields**
- **A Few Words About Multiselection**

**Grid**

The grid will help you draw geometry in some circumstances. For example, the grid will make it easier to draw profiles requiring parallel lines. For more information about defining a grid, see [Setting a Grid](#).

**Snap to Point**

If activated, this option makes your geometry begin or end on the points of the grid. As you are creating two-dimensional geometry the application forces points to the intersection points of the grid. Note that this option is also available in the Tools -> Options -> Drafting -> General tab. For more information, see [Setting a Grid](#).
In this example, the black spline was created with Snap to Point on. The points are on the grid.

Conversely, the highlighted spline was created with the option deactivated.

The autodetection capability works even if this option is on.

**Differentiating Between 2D Elements and Elements Generated from 3D**

If activated this option allows you to differentiate within the same view, two-dimensional elements created through the Interactive workbench from generated elements. It is very helpful when you need to add purely interactive elements on generated views.

The following example illustrates what you obtain.

The generated elements appear in gray whereas, the two-dimensional elements remain black.
This command is available only with the Generative Drafting license.

**Value Fields (Tools Toolbar)**

The values of the elements you sketch appear in the Tools toolbar as you move the cursor. In other words, as you are moving the cursor, the Horizontal (H), Vertical (V) Length (L) and Angle (A) fields display the coordinates corresponding to the cursor position.

You can also use these fields for entering the values of your choice. In the following scenario, you are going to sketch a line by entering values in the appropriate fields.

1. Click the line icon 

   The Tools toolbar displays the value fields.
As you are moving the cursor, the Horizontal (H), Vertical (V) Length (L) and Angle (A) fields display the coordinates corresponding to the cursor's position.

1. Click the Line icon from the Geometry creation toolbar.

   The Tools toolbar displays information on value fields.

2. Enter the coordinates of the First Point.

3. Enter the coordinates of the Second Point.

   OR

4. Enter the length (L) of the line.

5. Enter the value of the angle (A) between the line to be created and the horizontal axis.

   The line is created.

Depending on the number of fields available and the way you customized your toolbars, some fields may be truncated. What you need to do is just undock the Tools toolbars.

A Few Words About Multiselection

This task shows you that creating several corners is possible just by multiselecting points.
1. Multiselect the rectangle endpoints by pressing the Ctrl key and the cursor.
2. Click the Corner icon from the Geometry edition toolbar.
3. Enter a radius value in the Radius field that appears in the Tools toolbar.
4. The four corners are created at the same time with the same radius value.
Points

This task shows you how to quickly create points by clicking:

1. Click the Point icon from the Geometry creation toolbar.

2. Click once for each point to be created. A point is created where you clicked.

The logical constraints detected during the creation of a point are stored in memory.
Points Using Coordinates

This task shows you how to create points by specifying coordinates.

1. Click the Point By Using Coordinates icon from the Points toolbar.

The Point Definition dialog box is displayed.

2. Enter the point coordinates (h and v) from the Point Definition dialog box. You can use a cartesian or polar definition.

3. Click OK. The point is created.
This task shows how to create a set of equidistant points on an arc. In other words, you can create points on the support of your choice. You only need to select the origin point, and specify the spacing and the number of points you wish.

Create an arc.

1. Click the Equidistant Points icon from the Points toolbar.

2. Select the starting point of the arc on which you wish to create five equidistant points.

3. Select the arc endpoint on the left to define the arc.

The Equidistant Points Definition dialog box is displayed.

Ten equidistant New Points is the default value.

The default spacing is 10mm.
4. Click the Reverse Direction button to reverse the creation direction. The points will then be created on the arc.

5. Enter the distance you need between each point. For example, 20mm.

6. Enter five as the desired number of points.

7. Click ok.

The points are created and distributed along the arc. You can edit them individually.

Note that if the support is edited, the points are not affected by modifications.

The symbol used for points in the geometry area can be customized using the Edit -> Properties command.
Lines

This task shows how to create a line between two points.

1. Click the Line icon from the Geometry creation toolbar.

2. Click to create the first point, and point elsewhere. A rubberbanding line follows the cursor, showing the shape of the line which will be created.

3. Click to create the second point. The logical constraints detected during the creation of a line are stored in memory.
Circles

This task shows how to create basic circles with no precision.

1. Click the Circle icon from the Geometry creation toolbar.

2. Click the intended center of the circle.

3. Move the cursor to see the circle being created. A rubberbanding circle follows the cursor as you drag it.
4. Click once you are satisfied with the size of the circle.

The logical constraints detected during the creation of a circle are stored in memory.
Three Point Circles

This task shows how to create circles by indicating three points.

1. Click the circle icon from the Geometry creation toolbar (Circles and Ellipse subtoolbar).

2. Click two points. The application previews a circle.

3. Click the third point. The circle is created.
<table>
<thead>
<tr>
<th>Up</th>
<th>Helpful Tools</th>
<th>Points</th>
</tr>
</thead>
<tbody>
<tr>
<td>Points Using Coordinates</td>
<td>Equidistant Points</td>
<td>Lines</td>
</tr>
<tr>
<td>Circles</td>
<td>Three Point Circles</td>
<td>Circles Using Coordinates</td>
</tr>
<tr>
<td>Arcs</td>
<td>Three Point Arc</td>
<td>Ellipses</td>
</tr>
<tr>
<td>Profiles</td>
<td>Splines</td>
<td>Rectangles</td>
</tr>
<tr>
<td>Oriented Rectangles</td>
<td>Parallelograms</td>
<td>Hexagons</td>
</tr>
<tr>
<td>Oblong Profiles</td>
<td>Curved Oblong Profile</td>
<td>Keyhole Profiles</td>
</tr>
</tbody>
</table>
Circles Using Coordinates

This task shows how to create circles specifying center point coordinates. By default, centers are created but if you do not need them you can specify this in the Options dialog box. For more information, please refer to Customizing Geometry Creation.

1. Click the Circle Using Coordinates icon from the Geometry creation toolbar (Circles and Ellipse subtoolbar).

The Circle Definition dialog box is displayed.

2. Enter the coordinates of the center point.

3. Enter the desired circle radius value.

4. Click OK.
The circle and its center point are created.
You can also use the Polar tab options for creating a circle. In other words, you will define the circle using the radius and angle of the center point.
Arcs

This task shows how to create an arc from a center point.

1. Click the arc icon from the Geometry creation toolbar (Circles and Ellipse subtoolbar).

2. Click to the intended center of the arc and drag the cursor. A circle appears.

3. Click when you are satisfied with the radius of your circle. This sets the first limit of the arc.

4. Now, moving the cursor clockwise and clicking, you would obtain this arc:

5. Moving the cursor counterclockwise and clicking, you would obtain this arc:
Three Point Arcs

This task shows how to create an arc using three reference points to define the required size and angle.

1. Click the Three Point Arc icon from the Geometry creation toolbar (Circles and Ellipse subtoolbar).

2. Point and click to where you wish the arc to begin. This point is the first point through which the arc will pass.

3. Click to the second point of the arc. An arc appears.

4. Point elsewhere and click again to create the last point of the arc. The logical constraints detected during the creation of an arc are stored memory.
Ellipses

There is a simple way for creating an ellipse: this task shows how to do so. An ellipse has two axes. The midpoint of each axis is the center point of the ellipse.

1. Click the Ellipse icon from the Geometry creation toolbar (Circles and Ellipse subtoolbar).

2. Click to create the first point.

3. Click to create the second point.
   The first major semi-axis of the ellipse is created.

4. Click to create the third point.
   The second semi-axis is created and the ellipse is displayed.
Profiles

This task shows how to create a profile using the different options of the profile command. You can create open or closed profiles. Profiles may be composed of lines, arcs or even curves.

1. Click the Profile icon from the Geometry creation toolbar.

   The Tools toolbar displays with Lines, Tangent Arcs and Three Point Arcs commands. The Line command is activated by default.

2. Click two points to create a line. A rubberbanding line follows the cursor, showing the next line which will be created.
3. Click the Tangent arc icon that is now available as you have created a line.

4. Drag the cursor and click where you wish to end the tangent arc. The tangency symbol is displayed.

5. Now, click the Three Point Arc icon.

6. Click two points as indicated.

An arc is created as well as the three points you clicked.

7. Click the Line icon and drag the cursor vertically to create the line as shown.

An arc is created as well as the three points you clicked.
Now you are going to create another line then a tangent arc but this time without using the command.

8. To create an arc as part of a profile drag and release at the point where you want to begin your arc rather than simply click for a line.

A rubberbanding arc follows the cursor, showing the arc which will be created. The arc is automatically tangent to the previous element.

9. Double-click to end the profile creation.
Splines

This task shows how to create a curve from scratch.

1. Click the Spline icon from the Geometry creation toolbar.

2. Click to indicate two points through which the curve passes.

3. Click as many times as needed to create the whole curve.

4. Double-click to end the curve.

Clicking the Select icon ends the curve too.
Rectangles

This task shows you how to create rectangles.

1. Click the Rectangle icon from the Geometry creation toolbar (Profiles subtoolbar).

2. Point to the intended first corner of the rectangle.

3. Drag to see the rectangle being created. A rubberbanding rectangle follows the cursor as you drag it.

4. Click to create the rectangle.
Up
Points Using Coordinates
Circles
Arcs
Profiles
Oriented Rectangles
Oblong Profiles

Helpful Tools
Equidistant Points
Three Point Circles
Three Point Arc
Splines
Parallelograms
Curved Oblong Profile

Points
Lines
Circles Using Coordinates
Ellipses
Rectangles
Hexagons
Keyhole Profiles
Oriented Rectangles

This task shows how to create a rectangle oriented in the direction of your choice.

1. Click the Oriented Rectangle icon from the Geometry creation toolbar (Profiles subtoolbar).

2. Click two points to create the first side of the rectangle.

3. Drag to see the rectangle being created.

4. Click to create the rectangle. The logical constraints detected during the creation of the rectangle are stored in memory.
<table>
<thead>
<tr>
<th>Up</th>
<th>Points Using Coordinates</th>
<th>Circles</th>
<th>Arcs</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profiles</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Oriented Rectangles</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Oblong Profiles</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Helpfull Tools</td>
<td>Equidistant Points</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Three Point Circles</td>
<td>Three Point Arc</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Splines</td>
<td>Parallelograms</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Curved Oblong Profile</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Points</td>
<td>Lines</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Circles Using Coordinates</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ellipses</td>
<td>Rectangles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hexagons</td>
<td>Keyhole Profiles</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Parallelograms

This task shows how to create a parallelogram.

1. Click the Parallelogram icon from the Geometry creation toolbar (Profiles subtoolbar).

If you activate the and options from the Tools toolbar. The constraints are shown and created. Refer to Helpful Tools and Customizing Constraints.

2. Click two points to create the first side of the parallelogram.

3. Drag to see the parallelogram being created.

A rubberbanding parallelogram follows the cursor as you drag it.

4. Click to create the parallelogram.

The logical constraints detected during the creation of a parallelogram are memorized.
Hexagons

This task shows how to create an hexagon.

1. Click the Hexagon icon from the Geometry creation toolbar (Profiles subtoolbar).

2. Click a point to define the first point of the hexagon.

3. Drag the cursor to define a radius value. CATIA previews the hexagon to be created.

4. You can move the cursor clockwise or counter-clockwise to position the hexagon.
5. Click a second point when you are satisfied with the radius value and the orientation of the hexagon.

The hexagon is created.
This task shows how to create an oblong profile. The steps required for creating this type of profile are similar to creating an ellipse.

1. Click the Oblong Profile icon from the Geometry creation toolbar (Profiles subtoolbar).

2. Click to create the first point and drag the cursor.

3. Click to create the second point.

   The first semi-axis of the profile is created.

4. Drag the cursor and click to create the third point.

   The second semi-axis is created and the oblong profile is displayed.
Curved Oblong Profile

This task shows how to create a curved oblong profile. A construction arc assists you in creating this element.

1. Click the Curved Oblong Profile icon from the Geometry creation toolbar (Profiles subtoolbar).

2. Click two points to define the radius of the construction arc.

   The second point you clicked is the first endpoint of the construction arc.

3. Move the mouse counterclockwise and click to define the second construction arc endpoint.

   The profile shape looks like this:
4. Move the mouse away from the construction arc to define the radius of both of the arcs at the end of the profile.

5. Click when you are satisfied with the radius value.

The construction arc radius as well as the profile ends radius are displayed. This a curved oblong profile:
Keyhole Profiles

This task shows how to create a keyhole profile.

1. Click the Keyhole Profile icon from the Geometry creation toolbar (Profiles subtoolbar).

2. Click one point.
   This point is the centerpoint of the arc.

3. Click another point.

4. Drag to define the width of the lower part of the profile and click when satisfied.

5. Drag the cursor to define the circle radius of the upper part of the profile.

6. Click when you are satisfied with the radius value.
This is a keyhole profile:
Editing 2D Elements

The Interactive Drafting workbench provides a simple method to edit 2D Geometry elements. Editing 2D elements means modifying their coordinates but also modifying their shapes using commands such as edit, relimit and break.
Modifying Element Coordinates

Modifying your sketch coordinates will impact the feature defined on this sketch: CATIA maintains associativity.

The instructions described below are valid for editing all elements. Note however, that profiles are not considered as entities when it comes to editing them. To edit a profile, you will need to edit the sub-elements composing it. This task shows how to edit the line coordinates.

1. Double-click the line you wish to edit.

The corresponding dialog box appears indicating the line coordinates.

2. Enter new coordinates for changing your end points.

3. Check the Construction Element option if you wish to change the line type.

4. Press OK.

Remember that the Edit -> Properties command lets you access and even edit two dimensional elements properties. Multiselection is not allowed before editing 2D elements.
Creating and Editing Corners

The corner is an arc tangent to two curves.

You can create rounded corners between consecutive lines, arcs, circles and any types of curves using the corner command which displays three trim options. Note that even if the curves are not consecutive, but simply intersect, the corner will be created.

By default, centers are created but if you do not need them you can specify this in the Options dialog box. For more information, please refer to Customizing Geometry Creation.

Corners with Both Elements Trimmed

This task shows how to create a corner between two lines and trim these lines.

1. Click the Corner icon. The possible corner options are displayed. The Trim all command is activated by default.

2. Keep this option and select the first line. The selected line is highlighted.

3. Select the second line. The second line is also highlighted, and the two lines are joined by the rounded corner which moves as you move the mouse. This lets you vary the dimensions of the corner.
4. Click when you are satisfied with the corner dimensions.
Both lines are trimmed to the points of tangency with the corner.

An Alternative Method

To create a corner between two consecutive lines created using the \textbullet{}, \textbullet{}, or the \textbullet{} commands, you can apply the method described above, but you can also use the alternative method illustrated below, which is even more simple.

1. Click the Corner icon \textbullet{} and for example, leave the default trim option.

2. Select the point intersecting the lines.
The selected point is highlighted and the two lines are joined by the rounded corner which moves as you move the mouse.
3. Click when you are satisfied with the dimensions of the corner.

Both lines are trimmed to the points of tangency with the arc.

To edit a corner, you need to reconsider the center point location. This task will show you how to do so.

1. Double-click the corner to be modified.
2. Select circle->definition from the contextual menu

The Circle Definition dialog box is displayed.

3. Enter a new radius value.
4. Click OK to confirm your operation

Repeat the above scenario to edit chamfers.
Creating Chamfers

You can create beveled corners between any types of curves (lines, splines, arcs and so forth.) using the Chamfer command which displays three trim options. Note that if the curves are not consecutive, but simply intersect, the chamfer will be created and the intersecting curves will be trimmed.

Chamfers with Both Elements Trimmed

This task shows how to create a chamfer between two lines while trimming them.

1. Click the Chamfer icon.
   The possible chamfer options are displayed. The Trim all option is the default option.

2. Select the line.
   The selected line is highlighted.

3. Select the second line.
   The second line is also highlighted, and the two elements are connected by a line representing the chamfer which moves as you move the mouse. This lets you vary the dimensions of the chamfer.

4. Click when you are satisfied with the dimensions of the chamfer.
   The chamfer is created.
An Alternative Method

To create a chamfer between two consecutive lines created with the Profile icon, or the command, you can also use the alternative method illustrated below:

1. Click the Chamfer icon and for example, leave the default trim option.

2. Select the intersection point as shown.

The selected point is highlighted and the two lines are joined by the chamfer which moves as you move the mouse.

3. Click when you are satisfied with the dimensions of the chamfer.

Both lines are trimmed.
Trimming Elements

This task shows how to relimit a line. The trim command lets you relimit lines or circles, or points, lines or circles.

1. Click the Trim icon from the Geometry edition toolbar (Relimitations subtoolbar).

   The Tools toolbar displays the Trim All option (default command).

2. Select the first line.

   The selected element is highlighted.

3. Select the second point, line or circle.

   The second element is highlighted too, and both elements are trimmed.

   If you select the same first element, it will be trimmed at the location of the second selection.

   The location of the trim depends on the location of the mouse:

4. Click where you are satisfied with the trimming of the two elements:

   First example

   Second example
Now, if you prefer to trim just one element, this task shows how to do so. In this example, we use a line. We could also use a circle.

5. Click the Trim icon from the Geometry edition toolbar (Relimitations subtoolbar).

6. Click the Trim one element icon from the displayed Tools toolbar.

7. Select the first line.

The selected line or circle is highlighted.

8. Select the second line.

The first line selected is trimmed.

If you select the same first element, it will be trimmed at the location of the second selection.
The location of the trimming depends on the location of the mouse.
Breaking Elements

The purpose of this task is to show how to break a line using a point on the line and then a point that does not belong to the line. The Break command lets you break any types of curves. The elements used for breaking curves can be any Sketcher element.

1. Click the Break icon from the Geometry edition toolbar (Relimitations subtoolbar).
2. Select the line to be broken.
3. Select the breaking element, that is a point.

The selected element is broken at the selection point. The line is now composed of two movable segments.

1. Click the Break icon from the Geometry edition toolbar (Relimitations subtoolbar).
2. Select the breaking point.
3. Select the line to be broken.
The application projects the point onto the line and creates another point.

The line is broken at the projected point. The line is now composed of two segments that can be moved.

Using the Break icon, you can also isolate points:
- if you select a point that limits and is common to two elements, the point will be duplicated.
- if you select a coincident point, this point becomes independent (is no more assigned a coincidence constraint).
Applying Transformations to 2D Geometry

The Interactive Drafting workbench provides a simple method to create transformation features on 2D Geometry. Transformation features are obtained by applying commands on existing elements.

Tasks

- Creating Symmetry
- Translating
- Rotating
- Scaling
Creating Symmetry

You can use the symmetry command whenever you wish to copy already existing 2D elements. You can repeat them using a line, construction line or an axis.

This task shows how to duplicate a circle.

Create a circle and an axis.

1. Select the circle to be duplicated by symmetry.

The Symmetry icon is now available.

2. Click the Symmetry icon from the Geometry edition toolbar.

3. Select the axis you have previously created.

The selected circle is duplicated and the application creates a symmetry constraint.
Translating

This task will show you how to create copies of elements using translation in the duplicate mode. Multi-selection is not available.

You may either perform a simple translation (by moving elements) or create several copies of two-dimensional elements.

Make sure the view is active.

1. Click the Translate icon from the Geometry edition toolbar (Transformations subtoolbar).

The Translation Definition dialog box displays and will remain displayed throughout the operation.

2. Enter the number of Instances you need (Instances). The duplicate mode is activated by default.

3. Select the element(s) to be translated.

You may select one 2D element to be translated or multiselect the entire two-dimensional geometry drawn on your sheet. See A Few Words About Multiselection.
4. Click the translation vector start point on the sheet or select an existing one.

5. In the Translation Definition dialog box, enter a precise value for the translation length. For example, 10 mm.

6. Use the Autodetection to maintain horizontality.

7. Click OK in the Translation Definition dialog box to end the translation.

The last translation is always highlighted. Thus, you may restart from the latter if you need more copies.
The Undo command is available from the toolbar, while you are translating elements.

- When the Duplicate mode is activated, only 2D geometry is translated, dimensions are not.
- When the Duplicate mode is deactivated, both 2D geometry and its associated dimensions are translated. Therefore associativity is maintained.
Rotating

This task will show you how to rotate elements. In this scenario, the geometry is simply moved. But note that, you can also duplicate elements with the Rotating command.

Make sure the view is active.

1. Click the Rotate icon from the Geometry edition toolbar (Transformations subtoolbar).

The Rotation Definition dialog box displays and will remain displayed all along your rotation.

2. Deactivate the Duplicate mode.

3. Enter the number of copies you need (Instances).

4. Select the geometry to be rotated. Here, multiselect the entire profile.

5. Click the rotation center point position or enter a precise value in the fields displayed.

6. Click a point for defining the reference line that will be used for computing the angle.

7. In the Rotation Definition dialog box, enter a precise value for the rotation angle. The step mode computes from 15 degrees to 15. But be the step mode activated or not, you may enter the value of your choice (for example, 92 degrees).
7. Click OK to end the rotation.

- When the Duplicate mode is activated, only 2D geometry is rotated, dimensions are not.
- When the Duplicate mode is deactivated, 2D geometry and the associated dimensions are rotated. Therefore, associativity is maintained.
Scaling

This task will show you how to scale an entire profile. In other words, you are going to resize a profile to the dimension you specify.

1. Click the Scale icon from the Geometry edition toolbar (Transformations subtoolbar).

The Scale Definition dialog box displays and will remain displayed all along your operation.

2. Select the element(s) to be scaled.

Note that you can first select either the geometry or the scaling icon. If you select the Scale icon first, multiselection capability is available.
The value fields display in the Tools toolbar.

3. Enter the newly scaled element center point value.

In the displayed Scale Definition dialog box:

5. Enter 0.5 as Scale Value:

This is what you obtain:

Note that you can also use the cursor and drag the geometry to the desired scale.

The helpful command is available from the toolbar, while you are scaling elements.
Manipulating Dimensions

The Interactive Drafting workbench provides a simple method to manipulate all types of dimensions using the following toolbar:

The Interactive Drafting workbench allows you creating and/or modifying given types of dimensions. This is described in detail in chapter called Before you Begin.
<table>
<thead>
<tr>
<th>Up</th>
<th>Manipulating the Drafting Shell</th>
<th>Creating Views</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating 2D Geometry</td>
<td>Editing 2D Elements</td>
<td>Applying Transformations</td>
</tr>
<tr>
<td>Manipulating Dimensions</td>
<td>Using Constraints</td>
<td>Manipulating Annotations</td>
</tr>
<tr>
<td>Manipulating the Dress-Up</td>
<td>Displaying and Editing Proper</td>
<td>Printing a CATDrawing Doc.</td>
</tr>
</tbody>
</table>
Before you Begin

Creating Dimensions

CATIA Interactive Drafting version 5 provides a unique and powerful command to create the following types of dimensions:

Dimensions created on one element
- Length dimensions
- Diameter dimensions
- Radius dimensions

Dimensions created on two elements
- Distance dimensions
- Angle dimensions

The dimension type will depend on the selected elements as explained hereafter:

Modifying the Dimension Attributes

CATIA Interactive Drafting version 5 provides a unique and powerful command to modify the following attributes at any time before you click to validate the dimension creation:
Modify while creating
- Type
- Measure direction

Modify while or just after creating
- Value position
- Overrun/blanking
- Inserted prefix
- Tool bar
Creating Dimensions

This task will quickly show you how to create a dimension. When creating a dimension on 2D elements (except points), CATIA lets you preview the dimensions to be created.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click from the Dimensioning toolbar.

2. Click a first element in the view.

3. If needed, click a second element in the view.
   The dimension type is automatically defined according to the selected elements.
   At this step, two icons allow positioning the dimension line either according to a reference element or to a reference view.

4. Click either the Reference Element icon or the View Reference icon from the tools toolbar.

5. Click the View Reference icon.

6. Click the drawing window for validating the dimension creation.
Note that if you right-click the dimension before creation, a contextual menu lets you modify the dimension type and its value orientation as well as add funnels.

Once the dimension is created, if you right-click you access the Properties options. Dimensions properties are detailed in Chapter Displaying and Editing Dimensions Properties.
Choosing Angle Dimension

This task will quickly show you how to create an angle dimension and perform in the meantime three kinds of modifications: new angle sector, new angle sector location or turning an angle sector into a supplementary sector.

Create two lines and apply an angle dimension to them (by selecting two line type elements).

1. Click from the Dimensioning toolbar.
2. Select the dimension line.
3. With the mouse, drag the angle dimension to the desired quadrant (or sector).

Lastly, you may turn the angle sector into a supplementary sector.

4. Press the Control key and select the dimension line.
You may move the dimension to a new sector by using the contextual menu:
Right-click the angle dimension and select the required Angle sector from the contextual menu. For example, Sector 3.
Modifying the Dimension Type

This task will quickly show you how to modify the type as you create the dimension. On other words, you modify the dimension attributes. In this particular example, we will apply a Radius Center dimension type to a hole.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a diameter dimension.

1. Click from the Dimensioning toolbar and a first element in the view.

2. If needed, click a second element in the view.

The dimension type is automatically defined according to the selected elements.

3. Right-click the dimension.

4. Select the required type from the displayed menu. For example, Radius Center.

The diameter dimension is automatically snapped to a radius dimension.
5. Click the drawing window for validating the dimension creation and if needed, modify the dimension location.
Modifying the Dimension Line Location

This task will quickly show you how to modify dimension line location very easily either before or after creating dimensions.

In this example, we will use a previously created distance dimension.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a distance dimension.

1. Click , if needed.
2. Select the dimension to be modified.
   The distance dimension is highlighted.
3. Select the dimension line.
4. Drag the dimension line to the new position.

You may modify the dimension line location using the extension line.
Modifying Dimension Value Text

Position

This task will quickly show you how to modify dimensions value text. In this example, we will use a previously created distance dimension.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a distance dimension.

1. Click , if needed.
2. Select the value text of the dimension.

3. Drag the value text to the new position.
4. Click to validate the position.
Modifying the Dimension Text Before/After

This task will quickly show you how to insert text before or after the value text.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a distance dimension.

1. Click , if needed.
2. Click the dimension to be modified.
3. Click the left red triangle.

The Insert Text Before dialog box displays:

4. Enter for instance \( L = \).
5. Click OK.

The Text Before is automatically inserted.

6. Click in the free space.
Up
Before you Begin
Creating Dimensions
Choosing Angle Dimension
Modifying the Dimension Type
Modifying the Dimension Line
Modifying the Dimension Value
Modifying the Text Before/After
Modifying Dimensions Over/Under
Creating Coordinate Dimension
Lining up Dimensions
Modifying Dimension Overrun/Blanking

This task shows you how to modify dimensions extension line overrun and/or blanking. In this example, we will use a previously created distance dimension.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a distance dimension.

1. Select the overrun or the blanking manipulator(s), as shown herebelow:

2. Drag the manipulator(s) to the new position, as shown herebelow:

3. If you need to be more precise, double-click the manipulator.

   The Overrrun/Blanking dialog box displays.

4. Enter the desired value for modifying a given blanking

5. If needed, deactivate the blanking/overrun to both extension lines sides option.
Before you Begin

Creating Dimensions

Choosing Angle Dimension

Modifying the Dimension Type

Modifying the Dimension Line

Modifying the Text Before/A

Modifying Dimensions Overr

Creating Coordinate Dimens)

Lining up Dimensions
Creating Coordinate Dimensions

This task will show you how to automatically create coordinate dimensions on 2D elements. Coordinates dimensions allow you defining the distance between a reference element and a 2D element.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Coordinate Dimension icon from the Dimensioning toolbar (Dimensions subtoolbar).

2. Select the element to be applied coordinates dimensions.

3. Click the free space.

The Coordinate dimension is automatically created, without preview.

4. Click the Coordinate dimension for modifying the position.

The clicked dimension is highlighted and the anchor point appears in Green.

5. Drag the dimension to the appropriate position.

The Green anchor point is associative with the element which has been applied a coordinate dimension.

Note that you are not allowed to create coordinate dimensions on 2D generated elements.
Up

Before you Begin

Creating Dimensions

Choosing Angle Dimension

Modifying the Dimension Type

Modifying the Dimension Line

Modifying the Dimension Value

Modifying the Text Before/After

Creating Coordinate Dimensions

Lining up Dimensions
Lining up Dimensions

This task will show you how to line up the following dimensions:

- Length dimensions
- Distance dimensions
- Radius dimensions (tangent)
- Diameter dimensions (tangent)
- Angle dimensions

You will first organize dimensions into a system with a linear offset. The offset will align the dimensions to each others as well as to the smallest dimension.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create distance dimensions.

1. Select the dimensions to be lined up.
2. Right click the selected dimensions and display the contextual menu.

You can also select Tools->Line-up items.

3. Click either a dimension or a 2D element as a reference. Or just click anywhere desired on the drawing.

The Line Up dialog box displays:

4. Enter the Offset desired value.
5. Click the Only organize into systems option.

The dimensions are now aligned:
If you click in the empty space, the linear offset between the smallest dimension and the reference is automatically set to 0 value. The space between two dimensions will be the space defined in Tools/Options/Dressup (Line Up) settings.

1. Click an element as dimension position reference.

2. Enter the required Linear offset value in the Line Up dialog box and deactivate the Only organize into systems option.

The smallest dimension positions according to the element selected and the 30 mm linear offset pre-defined.

If you click OK without entering any offset value in the Line Up dialog box, the dimension line position will be similar to the selected reference.
Before you Begin
Creating Dimensions
Choosing Angle Dimension
Modifying the Dimension Type
Modifying the Dimension Line
Modifying the Dimension Value
Modifying the Text Before
Modifying Dimensions
Creating Coordinate Dimensions
Lining up Dimensions
A constraint is some kind of a relationship that allows specifying the geometry. Via Autodetection, you may detect geometrical constraints dynamically. But Autodetection may simply be used for automatically detecting constraints without necessarily creating these constraints.
Before you Begin

What Is a Constraint?

A constraint is some kid of a relationship that allows specifying the geometry. In other words, if you modify the geometry afterwards via the geometry itself, these relations will be taken into account.

Two kinds of constraints can be applied. A geometrical constraint is a relationship that forces a limitation between one or more geometric elements. A dimensional constraint is a constraint which value limits geometric object measurement.

<table>
<thead>
<tr>
<th>Geometrical Constraints</th>
<th>Dimensional Constraints</th>
</tr>
</thead>
<tbody>
<tr>
<td>support lines and circles</td>
<td>distance</td>
</tr>
<tr>
<td>alignment</td>
<td>length</td>
</tr>
<tr>
<td>parallelism</td>
<td>angle</td>
</tr>
<tr>
<td>perpendicularity</td>
<td>radius/diameter/</td>
</tr>
<tr>
<td>tangency</td>
<td></td>
</tr>
<tr>
<td>concentricity</td>
<td></td>
</tr>
<tr>
<td>horizontality</td>
<td></td>
</tr>
<tr>
<td>verticality</td>
<td></td>
</tr>
<tr>
<td>fix</td>
<td></td>
</tr>
<tr>
<td>middle</td>
<td></td>
</tr>
<tr>
<td>equidistant</td>
<td></td>
</tr>
<tr>
<td>symmetrical</td>
<td></td>
</tr>
</tbody>
</table>

What Is Autodetection?

Via Autodetection, you may detect geometrical constraints dynamically.

CARE that when you use autodetecion, you do NOT necessarily create constraints.
What Creating Constraints Means?

You can create constraints as follows:

1. explicitly, via the existing Create Constraints command
2. via a dimension that you make to be a driving dimension constraint
3. via Autodetection, if you activate the Create Detected Constraints command. In other words, so that a detected constraint be automatically created.
Creating Constraints via Autodetection

This task shows you how to detect, create and visualize constraints. For example, let's create two constrained parallel lines.

1. Click the icon from the Tools toolbar.
2. Create a first line.
3. Create a second line.

Autodetection is only valid for certain elements on the drawing. More precisely, only the elements which the mouse last went over will be used for applying autodetection constraints.

No Autodection available ...

... go over the line to be used for detecting parallelism constraint.

Constraint is detected and created.

For visualizing detected and created constraints, make sure the Show Constraints command is on, or the Tools/Options (Drafting/Geometry) is set to the visualize option.
Creating Geometric Constraints

This task shows you how to set a relationship that forces a limitation between one or more geometric elements.

1. Select the geometrical elements to be constrained to each other, for example, two lines that are parallel.

2. Click the icon from the Geometry edition toolbar.

3. Modify the Constraint Definition dialog box. For example, activate the Parallelism switch.

4. Modify the position of one geometrical element. For example, one end point on one line.
The lines are driven so as to remain parallel to each other whatever the new position and/or length you assign to one of them.

- **SHIFT** keyboard switch allows deactivating autodetection.

- **CONTROL** keyboard switch allows locking the constraint currently created and thereby try to create others.

Constraints are not necessarily visualized. Check the Show Constraints command from the Tools toolbar or go to **Tools/Options** menu bar (Drafting/Geometry), if needed. You may also modify the constraint color and/or width.
Creating Dimensional Constraints

This task shows you how you can create dimensions that will drive associated constrained geometry.

Click the icon from the Dimensioning toolbar and create a dimension on the geometry previously selected. In this example, create a length dimension on a line.

1. Double-click the dimension.

2. Modify the dimension via the displayed Dimension Value dialog box.

If the Drive geometry switch is on, the double-clicked dimension becomes a constraint and behaves as a dimensional constraint.

The geometry is modified according to the driving dimension. Let's call it driven geometry. In other words, it is assigned the characteristics previously defined via Tools/Option (Drafting/Geometry).

In this particular case, driving geometry visualization is as follows:
SHIFT keyboard switch allows deactivating autodetection.

CONTROL keyboard switch allows locking the constraint currently created and thereby try to create others.

The constraint visualization defined characteristics can be visualized on the condition you activated the Show Constraints command.
Manipulating Annotations

The Interactive Drafting workbench lets you manipulate annotations. The tasks described in this section are presented in the following table:

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a FreeText</td>
</tr>
<tr>
<td>Creating an Associated Text from Scratch</td>
</tr>
<tr>
<td>Make an Existing Text Associative</td>
</tr>
<tr>
<td>Creating a Text with Leader</td>
</tr>
<tr>
<td>Adding a Leader to Existing Text</td>
</tr>
<tr>
<td>Moving a Text</td>
</tr>
<tr>
<td>Rotating a Text</td>
</tr>
<tr>
<td>Painting Existing Elements</td>
</tr>
<tr>
<td>Creating Geometrical Tolerances</td>
</tr>
<tr>
<td>Copying Geometrical Tolerances</td>
</tr>
<tr>
<td>Modifying Geometrical Tolerances</td>
</tr>
<tr>
<td>Creating a Datum Feature</td>
</tr>
<tr>
<td>Modifying a Datum Feature</td>
</tr>
<tr>
<td>Creating a Datum Target</td>
</tr>
<tr>
<td>Modifying a Datum Target</td>
</tr>
<tr>
<td>Creating a Balloon</td>
</tr>
<tr>
<td>Modifying a Balloon</td>
</tr>
</tbody>
</table>
Creating a Roughness Symbol
Creating a Welding Symbol
Creating a Geometry Weld
Modifying the Text Properties
Finding & Replacing Text

Up
Creating 2D Geometry
Manipulating Dimensions
Manipulating the Dress-Up Displaying and Editing Proper Printing CAT Drawing Document

Manipulating the Drafting Sheet
Editing 2D Elements
Using Constraints
Applying Transformations
Manipulating Annotations

Creating Views
Creating a Free Text

This task shows you how to create a text element. This text is a free text and may either wrap or not wrap. This text is assigned an unlimited width text frame even though this text may reach the frame boundary.

Create a rectangle.

1. Click the Text icon from the Annotations toolbar.

2. Click in free space to define a location for the text.

At this step, you may decide that you want the text to be wrapped. For this, click in the free space and then drag a frame corresponding to the text horizontal boundary.

The Text Editor dialog box is automatically displayed.

3. Enter the text in the dialog box edition field.

The text automatically appears on the drawing as you are entering it in the Text Editor dialog box.
In the case you created a wrapped text the text appears as shown opposite:

4. Click again in free space or select a command icon to end the text creation.

The resulting text appears as shown opposite:

If you click the Select icon to end the text creation, the text remains highlighted so that you can modify it.

Note that using the toolbar you may define the anchor point, text size and justification. You can set text properties either before or after you create text. Please refer to Setting Text Properties.
Creating an Associated Text from Scratch

This task shows how to create a text which you want to be associated to an element. It also shows you how this text will remain associated with the element.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create diameter dimensions.

1. Click the Text icon from the Annotations toolbar.
2. Select an element. Here, we will use a dimension.

The text frame is displayed as well as the Text Editor dialog box.

3. Enter the text in the Text Editor dialog box.
4. Click in free space or click the Select icon to end the text creation.
5. If needed, move the dimension to the desired location.

The text remains associated to the dimension.

Note that the text is associative to the whole selected element. In other words and in the case of a dimension, if you move the dimension text exclusively, the associated text will not move accordingly.

The table below lists the elements that can be assigned text:

<table>
<thead>
<tr>
<th>Elements That Can Be Assigned Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Annotations</td>
</tr>
<tr>
<td>text</td>
</tr>
<tr>
<td>datum feature</td>
</tr>
<tr>
<td>datum target</td>
</tr>
<tr>
<td>balloon</td>
</tr>
</tbody>
</table>
GD&T
roughness symbols
text

Dimensions
2D elements
points
circles
curves
arrow

Generative Draw Edges

Up
Creating a FreeText
Creating an Associated Text

Make an Existing Text Associated
Creating a Text with Leader
Adding a Leader to Existing

Moving a Text
Rotating a Text
Painting Existing Elements

Creating Geometrical Tolerances
Copying Geometrical Tolerances
Modifying Geometrical Tolerances

Creating a Datum Feature
Modifying a Datum Feature
Creating a Datum Target

Modifying a Datum Target
Creating a Balloon
Modifying a Balloon

Creating a Roughness Symbol
Creating a Welding Symbol
Creating a Geometry Weld

Modifying the Text Properties
Finding & Replacing Text
Making an Existing Text Associative

This task explains how, at any time once the text has been created, you can add a positional link between a text element and another element.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a text.

1. Click the Select icon.
2. Select any part of the text element (text, frame, or leader).
3. Right-click and select Positional Link->Create from the pop-up menu.
4. Select the element which you want the text to be linked to.

You may delete existing associativity using the same dialog but selecting the Delete option from the Link->Delete (Positional Link pop-up menu).

You may also display the offset distance between a text element and the element which it is linked to.
Creating a Text With a Leader

The Interactive Drafting workbench provides a command to create a text with a leader in free space or a text with a leader associated with an element.

Note that leader lines are displayed in either of the following ways, based on the standard set for the current drawing.

JIS or ISO text with leader

ANSI text with leader

Set the properties first if desired. You can set text properties either before or after you create text. Please refer to Setting text Properties for instructions.

1. Click the Leader icon \( \text{T} \) from the Annotations toolbar (Texts subtoolbar).

2. Click in free space to define a location for the arrow end of the leader.

Instead of clicking in the free space, you can select an element you want the arrow end of the leader to be associated with:

- 2D lines
- 2D circles
- 2D points
- Curves
- Generative Draw edges

As in the case of free text, you can create text that wraps. For this, click and drag the cursor to create a text frame.

The Text Editor dialog box displays.

4. Enter the text in the dialog box.

5. To end the text creation, click again in free space or select a command icon.
If you click the Select icon, the text remains highlighted so that you can modify it.

The leader is associated with the element you selected. If you move either the text or the element, the leader stretches to maintain its association with the element. In the drawing below, the leader is associated with the box at the right edge, and it remains associated as the box is moved to different locations around the text.

If you change the element associated with the leader, CATIA keeps the associativity between the element and the leader.
Adding a Leader to Existing Text

This task shows you how to add a leader to text that was previously created.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a simple text.

Set the properties first if desired. You can set text properties either before or after you create text. Please refer to Setting text Properties for instructions.

1. Right click the text to be added a leader.

2. Select the Add Leader command that appears in the contextual menu.

3. Click the leader arrow end. The leader appears.

4. If needed, position the leader at the desired location.

To create as many leaders as required use Tools->Customize items and create the Add Leader command in a separate toolbar. You will then be able to double-click the Add Leader command and then click for locating the leader(s) to be created.
If several elements are selected as you activate the Add Leader command, the selection is cleared and a message asks you for selecting an annotation.

If you modify the text associated with the leader, associativity between the text and the leader is kept.
This task explains how to move a text element using either the cursor or x, y coordinates.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a text with a leader.

1. Click the Select icon.
2. Select any part of the text element (text, frame, or leader) and drag it to a new location.
If you want to move text using x,y coordinates, perform as follows:

1. Click the Select icon.
2. Select any part of the text element (text, frame, or leader).
3. Right-click and select Move from the pop-up menu.
4. Select either the Position tab or Translation tab.
   Use the Position tab to move the text relative to the origin of the drawing.
   Use the Translation tab to offset the text relative to its current location.
5. Enter the desired x,y coordinates and select Apply.
Creating a Free Text
Creating an Associated Text
Make an Existing Text Associate
Creating a Text with Leader
Adding a Leader to Existing
Moving a Text
Rotating a Text
Painting Existing Elements
Creating Geometrical Tolerances
Copying Geometrical Tolerances
Modifying Geometrical Tolerances
Creating a Datum Feature
Modifying a Datum Feature
Creating a Datum Target
Modifying a Datum Target
Creating a Balloon
Modifying a Balloon
Creating a Roughness Symbol
Creating a Welding Symbol
Creating a Geometry Weld
Modifying the Text Properties
Finding & Replacing Text
Rotating a Text

This task explains how to rotate a text element.

Open the Brackets_views.CATDrawing document from the online\samples\IntDrafting directory. Create a text with a leader.

1. Click the Select icon.

2. Select any part of the text element (text, frame, or leader).

3. Right-click and select Move from the pop-up menu.

4. Select the rotation tab.

5. Enter the desired angle and select Apply. For instance, enter 30 degrees.
This is what you get.
Re-Applying Existing Graphical Properties

This task shows you how to apply text graphical properties to texts already created. This is true for any type of Interactive Drafting element. In this task, we will take text as an example.

Create texts.

1. Select the elements to be painted, for example text selected via multi-selection.

2. Click the Painter icon from the Graphic Properties toolbar.

3. Select the text to be used as a model for selected texts.

The texts selected are automatically modified.
Creating Geometrical Tolerances

This task shows you how to create a feature control frame for geometrical tolerance annotations. You can also copy an existing feature control frame and then edit its content to create a new one. See Copying a feature Control Frame.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Geometrical Tolerance icon from the Dimensioning toolbar (Tolerancing subtoolbar).

2. Select any element, a point in free space, a dimension or a text.

3. Select again to position the feature control frame.

Selecting an element or a point in free space defines a position for the end of a leader.

- If you select any element:

- If you select a point in free space:

If you select a dimension or a text element, no leader is displayed. The feature control frame is positioned just below the element you selected.

- If you select a dimension:

- If you select a text element:
The Geometric Dimensioning And Tolerancing Parameters dialog box displays.

Select **Yes** to display in the Characteristic box only those symbols generally considered appropriate for the type of element selected.

Select **No** to display all characteristic symbols, regardless of the type of element selected.

4. In the Characteristic box, select a geometric characteristic for Line 1.

5. Define any of the following values, as appropriate, for Line 1 and/or Line 2:
   - diameter zone
   - tolerance feature modifier
   - primary datum feature modifier
   - secondary datum feature modifier
   - tertiary datum feature modifier

6. After you entered a value, press Enter or Tab to move to the next field.
   The feature control frame is updated as you define values for each field.
7. Click OK to confirm your operation and close the dialog box.
Copying Geometrical Tolerances

This task will show you how to copy an existing feature control frame and then edit the content for creating a new one. See Copying a feature Control Frame.

1. Click on the feature control frame you want to copy.
2. Right-click and select the Copy option from the contextual menu.
3. Select the element to which you want the feature control frame to be associated.
4. Right-click and select the Paste option on the contextual menu.
5. Double-click the copied feature control frame.
6. In the filter Symbols box, make sure that the desired option is activated.

Select **Yes** to display in the Characteristic box only those symbols generally considered appropriate for the type of element selected.

Select **No** to display all characteristic symbols, regardless of the selected type of element.

7. Modify any of the values.

After you enter a value, press Enter or Tab to move to the next field. The feature control frame is updated as you define values for each field.

8. Click OK to confirm your operation and close the dialog box.
Modifying Geometrical Tolerances

This task shows you how to modify a geometrical tolerance.

1. Double-click the feature control you want to modify.

The Geometric Dimensioning And Tolerancing Parameters dialog box displays.

2. Modify any of the values.
3. Click OK to confirm your operation and close the dialog box.

4. Click in the free space to validate the geometrical dimension modification.

In the filter Symbols box, make sure that the desired option is activated:

Select **Yes** to display in the Characteristic box only those symbols generally considered appropriate for the type of element selected.

Select **No** to display all characteristic symbols, regardless of the type of element selected.
Creating a Datum Feature

This task will show you how to create a datum feature.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Datum feature icon from the Dimensioning toolbar.

2. Select the attachment point of the datum feature.

3. Select the anchor point of the datum feature.

The Datum Feature dialog box displays with the datum feature character string.

4. Click OK.

CATIA provides a wysiwyg capability. In other words, when editing the character string, the modification is simultaneously taken into account.
The datum feature is created.

The datum feature is associative to the geometrical tolerance.
Modifying a Datum Feature

This task shows you how to modify a datum feature.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a datum feature.

1. Double-click the datum feature you want to modify.

   The Modify Text dialog box displays.

2. Modify the datum feature value.

3. Click OK to confirm your operation and close the dialog box.

4. Click in the free space to validate the datum feature modification.

---

1. Double-click the datum feature you want to modify.

2. Modify the datum feature value.

3. Click OK to confirm your operation and close the dialog box.

4. Click in the free space to validate the datum feature modification.
Creating a Datum Target

This task will show you how to create a datum target on a right projection view.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Datum Target icon.
2. Select the attachment point of the datum target leader.
3. Select the datum target anchor point.
4. The Datum Target dialog box displays: enter the required field.
5. The datum target preview is displayed.
6. Click OK.

CATIA provides a wysiwyg capability. In other words, when editing the character string, the modification is simultaneously taken into account.

The datum target is created.
Up
Make an Existing Text Associated
Moving a Text
Creating Geometrical Tolerances
Creating a Datum Feature
Modifying a Datum Target
Creating a Roughness Symbol
Modifying the Text Property:

Creating a FreeText
Creating a Text with Leader
Rotating a Text
Copying Geometrical Tolerances
Modifying a Datum Feature
Creating a Balloon
Creating a Welding Symbol
Finding & Replacing Text

Creating an Associated Text
Adding a Leader to Existing
Painting Existing Elements
Modifying Geometrical Tolerances
Creating a Datum Target
Modifying a Balloon
Creating a Geometry Weld
Modifying a Datum Target

This task shows you how to modify a datum target.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a datum target.

1. Double-click the datum target you want to modify.

The Modify Text dialog box displays.

2. Modify any of the datum target value.

3. Click OK to confirm your operation and close the dialog box.

4. Click in the free space to validate the datum target modification.
Up

Creating a Free Text

Creating an Associated Text

Make an Existing Text Associative

Creating a Text with Leader

Adding a Leader to Existing

Moving a Text

Rotating a Text

Painting Existing Elements

Creating Geometrical Tolerances

Copying Geometrical Tolerances

Modifying Geometrical Tolerances

Creating a Datum Feature

Modifying a Datum Feature

Creating a Datum Target

Modifying a Datum Target

Creating a Balloon

Modifying a Balloon

Creating a Roughness Symbol

Creating a Weld Symbol

Creating a Geometry Weld

Modifying the Text Properties

Finding & Replacing Text
Creating a Balloon

This task will show you how to create a balloon.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Balloon icon from the Annotations toolbar (Texts subtoolbar).

2. Select an element.

3. Click to define the balloon anchor point.

The Balloon Creation dialog box displays:

4. Enter the desired character string.

5. Click OK to confirm your operation.

CATIA provides a wysiwyg capability. In other words, when editing the character string, the modification is simultaneously taken into account.
Modifying a Balloon

This task shows you how to modify a balloon.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory. Create a balloon.

1. Double-click the balloon you want to modify.

   The Modify Text dialog box displays.

2. Modify the balloon value.

3. Click OK to confirm your operation and close the dialog box.

4. Click in the free space to validate the balloon modification.
Up
Make an Existing Text
Moving a Text
Creating a Datum Feature
Modifying a Datum Feature
Creating a Roughness Symbol
Modifying the Text Properties
Creating a Free Text
Creating a Text with Leader
Rotating a Text
Creating a Datum Target
Creating a Balloon
Finding & Replacing Text
Creating an Associated Text
Adding a Leader to Existing
Painting Existing Elements
Modifying Geometrical Tolerances
Copying Geometrical Tolerances
Modifying Geometrical Tolerances
Creating a Geometry Weld
Creating a Roughness Symbol

This task will show you how to create a roughness symbol.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Roughness symbol icon from the Annotations toolbar.

2. Select the attachment point of the roughness symbol.

The Roughness Symbol Editor dialog box displays:

3. Enter the required field.

4. Click OK.

Note that you can use the following symbols:
The roughness symbol is created.

You may modify the roughness symbol position by dragging it to the required location.

At any time, you can modify the roughness symbol. For this, double-click the roughness symbol to be modified and enter the modifications in the Roughness Symbol Editor dialog box.
Creating a Welding Symbol

This task will show you how to create a welding symbol.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Welding Symbol icon from the Annotations toolbar (Symbols subtoolbar).

2. Select the attachment point of the welding symbol.

3. Select a first element.

4. Select a second element.

The Welding creation dialog box displays

3. Enter the required field.

4. Click OK.
The welding symbol is created.

You may modify the welding symbol position by dragging it to the required location.

At any time, you can modify the welding symbol. For this, double-click the welding symbol to be modified and enter the modifications in the displayed dialog box.
Creating a Geometry Weld

This task will show you how to create a geometry weld.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Weld icon from the Annotations toolbar (Symbols subtoolbar).

2. Select a first element.
3. Select a second element.

The Welding Editor dialog box displays:

3. For example, modify the thickness from ten to five.
4. Click OK.

The geometry welding symbol is created as shown:
Up  Creating a Free Text  Creating an Associated Text
Make an Existing Text Assoc  Creating a Text with Leader  Adding a Leader to Existing
Moving a Text  Rotating a Text  Painting Existing Elements
Creating Geometrical Tolerances  Copying Geometrical Tolerances  Modifying Geometrical Tolerances
Creating a Datum Feature  Modifying a Datum Feature  Creating a Datum Target
Modifying a Datum Target  Creating a Balloon  Modifying a Balloon
Creating a Roughness Symbol  Creating a Welding Symbol  Creating a Geometry Weld
Modifying the Text Properties  Finding & Replacing Text
Modifying the Text Properties

This task explains how to set font, size, justification, and other display properties for a text element.

Create the text first, if needed. You can set text properties either before or after text creation.

1. Click the View menu from the menu bar and make sure the Text Properties command is activated.

The Text Properties toolbar is therefore displayed:

![Text Properties toolbar]

2. Select the text element.

3. Select the desired options from the Text Properties toolbar. For instance, the Italic and Bold options.

The properties you set are applied to any selected text. These properties will be applied to any new text you will create from now on.

The following table describes the options available from the Text Properties toolbar:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon" alt="Font Name" /></td>
<td>Font Name</td>
<td>Changes the style of text.</td>
</tr>
<tr>
<td><img src="icon" alt="Font Size" /></td>
<td>Font Size</td>
<td>Changes the size of text.</td>
</tr>
<tr>
<td><img src="icon" alt="Bold" /></td>
<td>Bold</td>
<td>Changes the weight of text. toggles between normal and heavy (bold).</td>
</tr>
<tr>
<td><img src="icon" alt="Italic" /></td>
<td>Italic</td>
<td>Changes the angle of text. Toggles between normal and slanted (italic)</td>
</tr>
<tr>
<td><img src="icon" alt="Underline" /></td>
<td>Underline</td>
<td>Adds a line under the text</td>
</tr>
<tr>
<td><img src="icon" alt="Strikethru" /></td>
<td>Strikethru</td>
<td>Adds a line through the center of the text.</td>
</tr>
<tr>
<td><img src="icon" alt="Overline" /></td>
<td>Overline</td>
<td>Adds a line above the text</td>
</tr>
<tr>
<td><img src="icon" alt="Superscript" /></td>
<td>Superscript</td>
<td>Raises the text above the normal text line.</td>
</tr>
<tr>
<td><img src="icon" alt="Subscript" /></td>
<td>Subscript</td>
<td>Lowers the text below the normal text line.</td>
</tr>
<tr>
<td><img src="icon" alt="Left Justify" /></td>
<td>Left Justify</td>
<td>Aligns multiple lines of text in the center of the text frame.</td>
</tr>
<tr>
<td><img src="icon" alt="Center Justify" /></td>
<td>Center Justify</td>
<td>Aligns multiple lines of text along the left edge of the text frame.</td>
</tr>
<tr>
<td><img src="icon" alt="Right Justify" /></td>
<td>Right Justify</td>
<td>Aligns multiple lines of text along the right edge of the text frame.</td>
</tr>
<tr>
<td><img src="icon" alt="Anchor point" /></td>
<td>Anchor point</td>
<td>Changes the position of the point that connects the text to the drawing or to an element. There are nine choices:</td>
</tr>
</tbody>
</table>

- Along the top of the text: left, center, or right
Frame  Draws a single-line frame around the text.

Along the vertical center of text: left, center or right
Along the bottom of the text: left, center, or right
Finding And Replacing Text

This task explains first how to locate a string of characters and then how to replace it in the following elements:
- balloons
- datum features
- datum targets
- dimensions
- text elements

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. In the menu bar, select the Edit->Find items. The Find dialog box is displayed:

2. Select any of the optional setting, as appropriate:

3. Enter the text you want to find and select Find Next. If the text exists in the drawing, the first instance found in search is highlighted.

4. Select Find Next to search for other instances.

Each time, an instance of the text string is found, you can replace it with a new string. To do this, type in the replacement text and select Replace.

5. A pop-up window is displayed when the search is complete.

6. Click OK to end your search.

7. Select Close to quit the Find dialog box.
Now, to replace a string of characters proceed as follows:

1. In the menu bar, select Edit->Replace. The Replace dialog box is displayed:

2. Select any of the optional settings as appropriate.

3. Key in the "find"string and select Find Next. If the string exists in the drawing, the first instance found in the search is highlighted.

4. Key in the replacement text.

5. Select one of the replace options:
   - To replace only the highlighted instance of the text, select Replace.
   - To replace all instances of the text, select Replace All.

6. If needed, select Find Next to search for other instances.

7. The search Complete pop-up window displays.

8. Click OK and quit the Replace dialog box.
Manipulating the Dress-Up of a View

The Interactive Drafting workbench provides a simple method to create the following view dress-up elements on existing on 2D elements.

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating Center Lines</td>
</tr>
<tr>
<td>Modifying Center Lines</td>
</tr>
<tr>
<td>Creating Threads</td>
</tr>
<tr>
<td>Creating Axis Lines</td>
</tr>
<tr>
<td>Creating an Area-Fill</td>
</tr>
<tr>
<td>Creating Arrows</td>
</tr>
</tbody>
</table>

Up
Creating 2D Geometry
Manipulating Dimensions
Manipulating the Dress-Up of a View
Displaying and Editing Properties
Creating Views
Editing 2D Elements
Using Constraints
Applying Transformations
Manipulating Annotations
Printing a CATDrawing Doc.
Creating Center Lines

This task will show you how to apply center lines to a circle.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Center line icon from the Dressup toolbar (Axis and Threads subtoolbar).

2. Select a circle.

The circle is automatically applied center lines.

You may create a center line according to a linear reference.

1. Click the center line with a reference icon.

2. Select the circle to be applied a center line.

3. Select the reference line.

The center line created is associative with the reference line.

You may create a center line according to a circular reference (a point or a circle).

1. Click .

2. Select the circle to be applied a center line.

3. Select the reference circle.
You can multi-select circles before you enter the command and thereby apply center lines to the selected circles.
Modifying Center Lines

This task will show you how to modify a center line.

Open the Brackets_views.CADrawing document from the \online\samples\IntDrafting directory. Create center lines.

1. Click the center line.
   Green end points appear.

2. Select any end point and drag to the new position.
   The center line extremity length is modified globally.

Now to modify the center line extremity length locally:
1. Click the center line. Green end points appear.
2. Press the Ctrl Key while selecting any end point and drag to the new position.

The center line extremity length is modified locally.

Multi-selection can be performed to modify center lines

You can also modify the center line using the contextual menu via the Properties dialog box.

The same method applies to axis lines.
Creating Threads

The Interactive workbench provides two commands to create threads. You can either create a thread with a reference or without a reference.

This task will show you how to apply a thread to a hole without a reference first and with a reference.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Drawing window, and click from the Axis and Threads toolbar.

Activating this command displays two options in the Options toolbar.

2. Select either the "Tap" or the "Thread" type.

The "Tap" type is activated by default.

3. Select the "Thread" type.

4. Select a circle to be applied a thread.

CATIA allows multiselection of 2D elements.

The thread that appears on the circle is assigned a standard radius and representation (compliant with the selected standard). The thread is automatically "thread" type.
You may create threads with a circle, a point or a line as reference. For example, if you use a line as reference:

1. Click the Drawing window.

2. Click the Thread with reference icon from the Options suntoolbar.

3. Activating this command displays two options in the Options toolbar.

4. Select the "Reference Thread" type from the options toolbar as shown opposite.

5. Select a circle.

6. Select a reference line:

   The thread that appears on the circle is assigned a standard radius and representation (compliant with the selected standard). The thread is automatically "thread" type.

   You can multi-select circles before you enter the command and thereby apply center lines to the selected circles.
Creating Axis Lines

This task will show you how to create an axis line.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Drawing window, and click the Axis Line icon from the Dressup toolbar (Axis and Threads toolbar).

2. Select the two lines.

3. The axis line is created.

If needed, you may select two non-parallel lines that are not colinear.
Both for center lines and axis lines, a default overrun is created.

If you need to modify an axis line, please refer to Modifying a center line as the method is similar. Note that multiselection can be performed for modifying axis lines.
Creating the Area-Fill

This task will show you how to apply to an existing hatching pattern a new area-fill.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

Hatching patterns can only be applied to area-fills resulting from sketched elements.

1. Click the Drawing window, and click the pattern chooser from the Graphic Properties toolbar.

The Pattern dialog box displays:
2. Select the representation you need.

3. Click within the area to be filled.
If you perform modifications to the filled area, the pattern will be modified accordingly. Make sure the view is active.
Creating Arrows

This task will show you how to create an arrow. For example to precise the kind of hole to be applied.

Open the Brackets_views.CATDrawing document from the \online\samples\IntDrafting directory.

1. Click the Drawing window, and select the Arrow command from the menu bar.

2. Click a point.

3. Click an object.

The arrow and the selected object are associative.
You may also either indicate two points or select two objects.

If you need to edit the arrow, use the green end points or right-click the arrow and select the properties options. You can modify its graphical visualization and location.
# Displaying and Editing Properties

This section discusses the way for quickly accessing and editing information concerning two-dimensional geometry, dress-up elements, annotations and dimensions. The data you access varies depending on the element you select, but you always access it using the Edit Properties command.

## Tasks

<table>
<thead>
<tr>
<th>2D Geometry Properties</th>
<th>Dress-up Graphic Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Annotation Font Properties</td>
<td>Annotation Frame and Position Properties</td>
</tr>
<tr>
<td>Annotation Graphic Properties</td>
<td>Dimension's Text Properties</td>
</tr>
<tr>
<td>Dimension Value Properties</td>
<td>Dimension Tolerance Properties</td>
</tr>
<tr>
<td>Dimension Extension Line Properties</td>
<td>Dimension Line Properties</td>
</tr>
</tbody>
</table>

Other tasks include:

- Creating 2D Geometry
- Manipulating Dimensions
- Manipulating the Drafting Sheet
- Creating Views
- Editing 2D Elements
- Using Constraints
- Applying Transformations
- Manipulating Annotations
- Displaying and Editing Properties
- Printing a CATDrawing Docu
Editing 2D Geometry Feature Properties

Gathered in a same dialog box, the two-dimensional geometry properties consists of different indications you will have sometimes to refer to. This task explains how to access and if needed, edit the information. Open a CATDrawing document.

1. Select a 2D element on the CATDrawing you opened.

2. Select the Edit Properties command or select the Properties command from the contextual menu.

The Properties dialog box displays with Feature Properties and Graphic tabs.

The Feature Properties tab edits the Name field.

3. Enter a new name for the element in the field. The information displayed informs about the creation of the elements.

4. Click OK to validate.
Editing Dress-Up Element Graphic Properties

Gathered in a same dialog box, the two-dimensional geometry properties consists of different indications you will have sometimes to refer to. This task explains how to access and if needed, edit the information.

Open a CATDrawing document.

1. Select a 2D element on the CATDrawing you opened.

2. Select the Edit-> Properties command or select the Properties command from the contextual menu.

   The Properties dialog box displays, containing the Feature Properties and Graphic tabs that deal with Dress-up elements.
4. Click the Graphic tab and modify the line and curves color, for example.

CATIA takes any modification into account. For more information on graphic properties, please refer to CATIA-Infrastructure User's Guide Version 5.

5. Click OK.
Editing Annotation Font Properties

Gathered in a same dialog box, the annotations properties consists of different indications you will have sometimes to refer to. This task shows how to access and if needed, edit the information.

Open a CATDrawing document.

1. Select an annotation on the CATDrawing you opened.

2. Select the Edit ->Properties command or select the Properties command from the contextual menu.

The Properties dialog box displays, containing the following Font tab.

![Properties Dialog Box]

- **Font:**
  - Monospac821 BT
  - ROM1
  - ROM2
  - ROM3
  - SICH

- **Style:**
  - Regular
  - Italic
  - Bold
  - Bold Italic

- **Size:**
  - 0.138 in
  - 0.25 in
  - 0.35 in
  - 0.5 in
  - 0.7 in

- **Underline:**
  - (None)

- **Color:**
  - Black

- **Attributes**
  - Strike Thru
  - Superscript
  - Overline
  - Subscript

- **Preview**
  - AaBbCcYyZz
Editing Annotation Frame/Position Properties

Gathered in a same dialog box, the annotations properties consists of different indications you will have sometimes to refer to. This task shows how to access and if needed, edit the information.

Open a CATDrawing document.

1. Select an annotation on the CATDrawing you opened.

2. Select the Edit ->Properties command or select the Properties command from the contextual menu. The Properties dialog box displays, containing the following Frame and Position tab.

![Properties dialog box](image-url)
Gathered in a same dialog box, the annotations properties consists of different indications you will have sometimes to refer to. This task shows how to access and if needed, edit the information.

Open a CATDrawing document.

1. Select an annotation on the CATDrawing you opened.
2. Select the Edit ->Properties command or select the Properties command from the contextual menu.

The Properties dialog box displays, containing the following Graphic tab.

![Properties dialog box](Image)
CATIA takes any modification into account. For more information on graphic properties, please refer to CATIA-Infrastructure User's Guide Version 5.
Editing Dimension's Text Properties

Gathered in a same dialog box, the dimensions properties consists of different indications you will have sometimes to refer to. This task explains how to access and if needed, edit the information.

Open a CATDrawing document.

1. Select a dimension (whatever the type) on the CATDrawing you opened.
2. Select the Edit Properties command or select the Properties command from the contextual menu.

The Properties dialog box displays, containing the following tabs dealing with dimensions:

- **Prefix - Suffix**
- **Main Value**
- **Main Value**
- **Dual Value**
- **Dimension score options**
  - **Main**: All
  - **Dual**: No score
- **Dimension frame options**
  - **Element**: Value+tolerance+t
  - **Group**: Main
Editing Dimension Value Properties

Gathered in a same dialog box, the dimensions properties consists of different indications you will have sometimes to refer to. This task explains how to access and if needed, edit the information.

Open a CATDrawing document.

1. Select a Dimension (whatever the type) on the CATDrawing you opened.

2. Select the Edit Properties command or select the Properties command on the contextual menu.

The Properties dialog box displays, containing the following Value tab.
Editing Dimension Tolerance Properties

Gathered in a same dialog box, the dimensions properties consists of different indications you will have sometimes to refer to. This task explains how to access and if needed, edit the information.

Open a CATDrawing document..

1. Select a Dimension (whatever the type) on the CATDrawing you opened.

2. Select the Edit Properties command or select the Properties command on the contextual menu.

The Properties dialog box displays, containing the following Tolerance tabs.
Editing Dimension Extension Line Properties

Gathered in a same dialog box, the dimensions properties consists of different indications you will have sometimes to refer to. This task explains how to access and if needed, edit the information.

Open a CATDrawing document..

1. Select a Dimension (whatever the type) on the CATDrawing you opened.

2. Select the Edit Properties command or select the Properties command on the contextual menu.
   The Properties dialog box displays, containing the following Extension Line tab.
Editing Dimension Line Properties

Gathered in a same dialog box, the dimensions properties consists of different indications you will have sometimes to refer to. This task explains how to access and if needed, edit the information.

Open a CATDrawing document..

1. Select a Dimension (whatever the type) on the CATDrawing you opened.

2. Select the Edit Properties command or select the Properties command on the contextual menu.

The Properties dialog box displays, containing the following Dimension Line tab.

![Dimension Line Properties Dialog Box](image)
Printing a CATDrawing Document

The Interactive Drafting workbench provides a simple method to print one or more sheets inserted in your document.

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quick Print</td>
</tr>
<tr>
<td>Current Display Settings</td>
</tr>
</tbody>
</table>

- Up
- Creating 2D Geometry
- Manipulating Dimensions
- Manipulating the Dress-Up
- Manipulating the Drafting Sheet
- Editing 2D Elements
- Using Constraints
- Creating Views
- Applying Transformations
- Manipulating Annotations
- Displaying and Editing Properties
- Printing a CATDrawing Document
Printing a Document Quickly

This task will show you how to quickly print a given sheet.

Open a CATDrawing document. Create a circle, a line and a profile on this document.

1. Select File -> Print Preview from the menu bar.

   The Print Preview dialog box is displayed.

2. Press OK.

   Image of a CATDrawing document with a circle, a line and a profile.
3. Select File -> Print from the menu bar.

The Print dialog box displays.

4. Click the required options from the box.
5. Press OK.

You may print either all or given sheets (the sheet selected or a given number of existing sheets).

You may also print the views currently displayed on your screen (Current display option).
You may also choose the **number of copies** you need to print.

For details on Options, see [CATIA - Infrastructure User's guide Version 5](https://example.com).

By default the sheet to be printed will **Fit to Printer Format**. The printer default format will be used whatever the sheet format. Let's say the printer format is Portrait. If you check the options as described below, the sheet will be previewed and printed as follows.

- Best Orientation/Fit to printer format/Clip to the sheet format
Fit to printer format/Clip to the sheet format

<table>
<thead>
<tr>
<th>Fitting choice</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Best orientation</td>
<td></td>
</tr>
<tr>
<td>Fit to printer format</td>
<td>✔️</td>
</tr>
<tr>
<td>Clip to the sheet format</td>
<td></td>
</tr>
</tbody>
</table>
Clip to the sheet format

- Fitting choice
  - [ ] Best orientation
  - [ ] Fit to printer format
  - [x] Clip to the sheet format
Best orientation/Clip to the sheet format

<table>
<thead>
<tr>
<th>Fitting choice</th>
</tr>
</thead>
<tbody>
<tr>
<td>Best orientation</td>
</tr>
</tbody>
</table>
Let's start from a new drawing:
Printing a Document After Modifying Current Display Settings

This task shows how to modify the settings of a document you will then print.

Create views on different sheets with the Landscape orientation.

1. Select File -> Print from the menu bar.
   The Print dialog box is displayed.
2. Click the required Printer options from the dialog box.
3. Activate the Current display option.
4. Click the Options option from the box.
5. If needed, select the Color tab.
6. If needed, select the Banner tab.

7. If needed, select the Various tab.

8. Click OK.

9. Click the Settings option from the Print dialog box. The Layout dialog box is displayed.

10. Activate the Fit in Page option.

11. For example, click the center switch for positioning.
12. Press OK.

13. Select the Print Preview option from the Print dialog box. The Print Preview dialog box is displayed.

14. Press OK. The Print dialog box is displayed.

15. Press OK to launch the printing operation.
Advanced Tasks

See CATIA - Infrastructure User's guide Version 5 for details on DXF/DWG files.
This section contains the list of the icons and menus which are specific to Interactive Drafting workbench. You may read these pages whenever you need to know greater details on these commands documented in other parts of the guide.

<table>
<thead>
<tr>
<th>Theme</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interactive Drafting Menu Bar</td>
<td>Describe access to view and dimension creation, annotation and geometry creation as well as sheet management</td>
</tr>
<tr>
<td>Interactive Drafting Toolbar</td>
<td>Describe how to manipulate a CATDrawing and how to insert or edit views, dimensions, annotations sheets and sketcher or 2D elements</td>
</tr>
</tbody>
</table>
Interactive Drafting Menu Bar

In this chapter we will describe the various menus, submenus and items specific to the Interactive Drafting workbench.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td>Save the document to the required format, customize the sheet and print it after modifying the settings if needed.</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td>Manipulate selected objects</td>
</tr>
<tr>
<td><strong>Insert</strong></td>
<td>Insert various types of elements</td>
</tr>
<tr>
<td><strong>Tools</strong></td>
<td>Set user preferences</td>
</tr>
</tbody>
</table>
File

For all File menu items, see the CATIA Infrastructure User's Guide
Edit

Also refer to the CATIA Infrastructure User's Guide.

For... See...

Background Creating a Frame Title Block
Insert

For...
- Annotations...
- Dimensions...
- Dressup...
- Sketcher...
- Transformations...
- Constraints...
- Views...
- New Sheet...

See...
- Annotations Creation
- Creating Dimensions
- Manipulating the Dress-up of a view
- Geometry Creation
- Creating Transformations
- Setting Constraints
- Creating Views
Tools

Also refer to the CATIA Infrastructure User's Guide.

For...

See...

Line-Up

Lining up Dimensions

Layers And Filters
Interactive Drafting Toolbars

This section describes the various icons of the Interactive Drafting workbench. The toolbars are located on each side of the workbench in the default set-up.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry Creation</td>
<td>Create geometry</td>
</tr>
<tr>
<td>Transformations</td>
<td>Transfom existing 2D elements</td>
</tr>
<tr>
<td>Annotations</td>
<td>Add annotations to existing views by creating them</td>
</tr>
<tr>
<td>Dressup</td>
<td>Add Dressup elements on the drawing</td>
</tr>
<tr>
<td>Dimensions</td>
<td>Create all types of dimensions needed for your drawing</td>
</tr>
<tr>
<td>Constraints</td>
<td>Add constraints to elements on the drawing</td>
</tr>
<tr>
<td>Properties</td>
<td></td>
</tr>
<tr>
<td>Dimensions Properties</td>
<td>Modify the dimensions properties</td>
</tr>
<tr>
<td>Text Properties</td>
<td>Modify the text properties</td>
</tr>
<tr>
<td>Graphic Properties</td>
<td>Modify the graphic properties of all kind of features</td>
</tr>
<tr>
<td>Tools</td>
<td>Activate display and positionning tools</td>
</tr>
<tr>
<td>Use Defaults</td>
<td>Reset the default parameters</td>
</tr>
</tbody>
</table>
Geometry Creation

- See Points
- See Points Using Coordinates
- See Equidistant Points
- See Lines
- See Circles
- See Three Point Circle
- See Circles Using Coordinates
- See Ellipses
- See Arcs
- See Three Point Arc
- See Profiles
- See Curves
- See Rectangles
- See Oriented rectangles
- See Parallelograms
- See Hexagons
- See Oblong Profiles
- See Oblong Arcs
- See Keyhole Profiles

Up
Annotations
Constraints
Tools
Geometry Creation
Dress-Up
Text Properties
Use Defaults
Transformations
Dimensions
Graphic Properties
Views toolbar
Annotations

- See Creating Text
- See Creating & Editing Text with Leader
- See Manipulating Geometrical Tolerances
- See Creating a Datum Feature
- See Creating a Datum Target
- See Creating a Balloon
- See Creating a Roughness Symbol
- See Adding a Leader
See [Creating a Center Line](#) and [Modifying a Center line](#)

See [Creating a Center Line](#) and [Modifying a Center line](#)

See [Creating a Thread](#)

See [Creating a Thread](#)

See [Creating an Axis Line](#)

See [Creating the Area-Fill](#)

See [Creating an Arrow](#)
Dimensions

See Creating Dimensions
See Creating Coordinate Dimensions
See Setting Constraints
Text Properties

See Setting Text Properties
Graphic Properties

See Displaying and Editing Dress-Up Element Properties
<table>
<thead>
<tr>
<th>Tools</th>
<th>Up</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Annotations</td>
</tr>
<tr>
<td></td>
<td>Constraints</td>
</tr>
<tr>
<td></td>
<td>Tools</td>
</tr>
<tr>
<td>Geometry Creation</td>
<td>Dress-Up</td>
</tr>
<tr>
<td></td>
<td>Text Properties</td>
</tr>
<tr>
<td></td>
<td>Use Defaults</td>
</tr>
<tr>
<td>Transformations</td>
<td>Dimensions</td>
</tr>
<tr>
<td></td>
<td>Graphic Properties</td>
</tr>
<tr>
<td></td>
<td>Views toolbar</td>
</tr>
</tbody>
</table>
Use Defaults

Resets to default parameters
Views

See Creating Views
Customizing

This section mentions the different types of setting customization you can perform. The tasks you can perform are:

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting a grid</td>
</tr>
<tr>
<td>Customizing Constraints</td>
</tr>
<tr>
<td>Customizing Geometry Creation</td>
</tr>
<tr>
<td>Customizing General Settings</td>
</tr>
<tr>
<td>Customizing Autodetection</td>
</tr>
<tr>
<td>Customizing Company Standard Management</td>
</tr>
</tbody>
</table>
Glossary

A

absolute position  A sheet coordinates.
angle dimension  Dimension applied to one or two linear elements or to circular elements.

C

chained dimension  Dimension presentation mode made of a system
chamfer dimension  Dimension applied to a chamfer

D

datum feature  An element defining a contacting surface on a part.
datum target  An element defining a contacting surface on a part and represented by spherical or pointed locating pins.
detail sheet  A sheet that is used as an intermediate catalog for positioning 2D geometry elements that will be instantiated afterwards.
diameter dimension  Dimension representing either a radius or a diameter.
distance dimension  Dimension representing the dimension between two elements be they linear or circular type.
ditto  An instantiation of a 2D element that is stored on a detail sheet.
document  A common unit of data (typically a file) used in user tasks and exchanged between users. When saved on disk, a document is given a unique filename by which it can be retrieved.
dress-up  A graphical attribute of a 2D element.

O

object  In the Drafting workbench, there are two kinds of object: activated and selected. The view frame of an activated object is displayed in red.

P

part  A 3D entity obtained by combining different features in the Part Design workbench.
radius dimension  Dimension applied to a circle, semi-circle or arc of a circle.

sheet  A set of views. Several sheets may be created in the Drafting workbench.

standard  The international conventions that are supported in the Drafting workbench: ANSI, ISO and JIS.

template  In the Drafting workbench, an object that is included in the document (for example, the title block).

title block  A frame which contains the title block.

view frame  A square or rectangular frame that contains the geometry and dimensions of the view.
Index

A

area-fill  
arow  
axis line

B

balloon  
Break command

C

center line  
commands  
  Break  
  Circle  
  Circle with center point coordinates  
  Point  
  Point specifying coordinates  
  Coordinate dimension  
creating  
  area-fill  
arow  
axis line  
balloon  
center line  
coordinate dimensions  
datum feature  
dimension  
distance dimension  
points
D

datum feature

datum target
dimensions
distance dimension
dressup

DXF format

DXF geometry

G

geometrical tolerance

M

menu bar
modifying
center line
distance dimension
text

P

Point command
points
creating

S

sheet
creating
text
thread
toolbar

workbench