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Preface
The CATIA Version 5 Systems Routing product enables you to design all production
systems routing within a plant The main focus of the product is to provide capabilities
for preliminary routing of production systems, but capabilities are also provided to
evolve the preliminary routing to the detailed production routing of the plant. All of this
is accomplished through a very simple and highly intuitive interface which combines
traditional 2D layout paradigms with the 3D capabilities to allow you to build a full 3D
digital representation of the production routing within a plant.
The Systems Routing product supports all routing disciplines, including conveyor,
ductwork, raceway, piping, and tubing. In conjunction with other digital plant design
related products, such as CATIA Version 5 Plant Layout, Systems Routing can be
used to provide complete plant layout capabilities. These products, together with the
complete CATIA Version 5 product portfolio, provide the complete ability to design and
optimize plant layout.
The Systems Routing User's Guide has been designed to show you how to create
production routing systems within a plant. Based on design factors and differing
industries and domains, different design approaches may be undertaken. This book
provides an overview of the product and illustrates specific design procedures to aid
your system routing efforts.

About This Book
This book describes how to use the CATIA Version 5 Systems Routing product.
Before you read it, you should be familiar with basic CATIA Version 5 concepts such
as document windows, standard tool bars, and view tool bars.
To get the most out of this guide, you should start with the tutorial in the Getting
Started section. It demonstrates how to create some basic elements of a plant in a
hierarchical structure.
The remaining sections of the book describe in detail the procedures for using all of the
features of the Systems Routing. The procedures are divided into basic, advanced,
and customization sections.

Getting Started
The following short tutorial provides an introduction to the CATIA Version 5 Systems
Routing product, It is intended to give you a feel for the product's capabilities in a few
step-by-step scenarios, which are listed below.

Entering the Systems Routing Workbench
Creating a Conveyor System
Creating a Network
Routing a Run
Placing Parts on a Run

These tasks can be completed in about 15 minutes.

Entering the Systems Routing Workbench
The first task show you how to enter the Systems Routing workbench.
1. Select the Start menu.
2. Select Equipment & Systems-> Systems Routing.

The Systems Routing workbench is loaded, and an empty CATProduct document is opened.

Creating a Conveyor System
In this exercise, you will create a conveyor system. A conveyor system is made
up of several conveyor networks. Conveyor networks are generally used to
move a product between a related series of workcells in a manufacturing plant.
1. Click the Distribution System icon
.
2. Select Conveyor System as the type.
3. Click OK.
The distribution system is created.

Creating a Network
Now that you have a conveyor system, create a conveyor network within the
system.
1. Double-click the Conveyor System in the specification tree to make it active.

.
2. Select the Logical Line icon
3. Select Conveyor Network as the type.
4. Click OK.
The Conveyor Network is created.
5. In the specification tree, click on the plus sign (+) next to the Conveyor System
to see the newly created conveyor network.

Routing a Run
With the conveyor network in place, you can create a run. In this case, a run
represents the actual path of the conveyor through the subset of the plant.
1. Double-click the Conveyor Network in the specification tree to make it active.

2. Click the run icon

.

The Routing dialog box is displayed.
3. Select Conveyor Run as the run type.
4. Click the Section Type icon.
5. Click the Rectangular Section Icon to define the section shape.
6. Click OK.
7. Click at 0,0,0 to start routing the conveyor run.
8. Click at 0,3000mm,0 to create the first segment of the conveyor run.
9. Click at 3000mm,3000mm,0 to create the second segment of the conveyor
run.
10. Double click at 3000mm,0,0 to complete the definition of the conveyor run.
You have created a conveyor network with one conveyor run. You can now
create additional runs using the same steps described above, or you can go on
to the last task of placing parts on the run.

Placing Parts on a Run
Now that you have a conveyor run in your network, you can add conveyor parts
to the run.
1. Select the File ->Open menu and navigate to the Parts Catalog Document.
Parts Catalog Document is located in your local CATIA installation in the
directory ../startup/components/catalogs.
The name of the catalog for this exercise is conveyor.catalog.
2. Select the menu Windows -> Tile Vertically to display the catalog and the
CATProduct window side by side.
You may need to zoom the catalog window to see the information properly.
3. In the catalog window, double-click the Conveyor entry.
4. In the catalog window, place your cursor over the part name
SWITCH_LH_M_OPF_PSPS and drag it to the middle segment of the conveyor
run in the CATProduct window. Release the mouse button to drop the part onto
the conveyor run.
The part is automatically placed on the run with the proper orientation.
You may continue to place additional parts (e.g., turns, tracks) to complete the
design of the conveyor run.

Basic Tasks
The basic tasks you can perform in the Systems Routing workbench are listed below.

Theme
General Layout Tools
Creating a Distribution
System
Creating a Logical Line
Routing Runs
Modifying Runs
Placing Parts

Purpose
Describes how to work with a grid to route and position elements, and how to
manipulate elements after you place them.
Describes how to create a distribution system (e.g., conveyor, piping, HVAC).
Describes how to create a logical line (e.g., conveyor, piping, HVAC).
Describes how to route runs.
Describes how to change the length, turn radius, or display of a run, as well as how to
connect and disconnect runs.
Describes how to open a catalog and place parts in a drawing.

Basic Layout Tools
The following procedures describe the basic tools available in the Systems Routing
product for general layout functions.

Making an Element Active

Using a Step Grid

Flipping Elements

Changing the Current Axis

Making an Element Active
This task shows you how to make an element in a drawing active. An element is
active when it is highlighted in blue in the specification tree.
1. You can make an element active by following any of these steps:
Double-click the element in the drawing or in the specification tree.
Select an element and then select the Activate Parent icon
to make
its parent active.
To activate an area, select the Activate Area icon and then select the
area.
2. Optional. You can change the display of elements that are not active using
the Toggle Dimming Mode icon on the General Environment Tool Bar:
When Dimming Mode is on, elements that are not active are dimmed.
When Dimming Mode is off, inactive elements are not dimmed.

Using a Step Grid
This task shows you how to use a grid to control the routing or placement of
elements in a drawing.
1. Select the increment field

and key in a value for the grid units.

2. Set any of the following step grid options on the General Environment Tools
tool bar:
Snap to steps off current axis
Coordinates displayed are relative to the current axis.
Snap to steps off last position
Coordinates displayed are relative to the current axis until you
indicate a point; after that, coordinates displayed are relative to
points that you indicate.
Snap to Drafting elements
If you have defined construction planes in the drawing, you can also use these
options:
Snap to XY construction planes
Snap to steps in the elevation (Z) direction
Snap to all construction planes

Flipping Elements
This task shows you how to flip a part that has been placed in your CATProduct
drawing.

1. Click the Flip Part Position icon
2. Select the part you want to flip.
The part is flipped.

.

Changing the Current Axis
This task shows you how to change the current axis.
When you activate an element, the current axis is reset to the axis of that
element. Changing the current axis changes the reference point by which
elements are routed and placed.
1. Click the Change Current Axis icon
.
2. Select the element you want to use as a reference.
The axis for the selected element is displayed.

Creating a Distribution System
This task describes how to create a distribution system. This high-level element
is a tool for organizing a plant design.
1. Select the Distribution System icon

.

The Distribution System dialog box is displayed.

2. Select the type of distribution system you want to create.

3. Click OK.

Creating a Logical Line
This task describes how to create a logical line. This high-level element is a tool
for organizing a plant design.
1. Make the appropriate element active in the specification tree.
2. Select the Logical Lines icon.
The Logical Lines Creation dialog box is displayed.

.
3. Select the type of logical line you want to create.

4. Click OK.

Routing Runs
You can create runs in any of the following ways.

Routing a Run on an Area
Routing From the End of a Path Reservation or
Run

Branching a Run

Routing a Run on an Area
This task shows you how to create a run on an area.

1. Select the Run icon

.

The Routing dialog box is displayed.

2. Define the type of run you want to create.

3. Define the routing mode for the run:
Point-to-point
Orthogonal
4. To define Section parameters, do the following:

a. Select the Section type icon..
The Section dialog box is displayed.

b. Define the section type and the corresponding parameters for
each of them:
No Section
Rectangular
Set Point
Height
Width
Display
Circular
Set Point
Diameter
Display
c. Select OK on the Section dialog box.
5. Optional. Key in a value for the turn radius.
6. Click in the drawing to define the routing points.
7. Double-click the last point to stop routing.

Routing From the End of a Path
Reservation or Run
This task explains how to route from the end of a path reservation or run.

If you route an element with the same type and parameter values as the "source"
element (i.e., the element from which the path reservation is routed), you can
specify whether the new element you route is a continuation of the source
element or a separate element. If you want to use the "Continue" option, be sure
that the parent for the source element is active before you begin.
1. Select the Run icon

.

The Routing dialog box is displayed.
2. Define the routing parameters.
See Creating a Run on an Area for instructions.
3. Select the element from which you want to route.
For path reservations or runs that are displayed with no section, select the
filled circle displayed when the cursor is at the end point of the line.
For path reservations or runs that are displayed with a section, base your
selection on the "cues" that are displayed as you move the cursor over the
element:
An outlined circle is displayed when your cursor is over the end
point of the section's centerline.
A filled circle is displayed when the cursor is over the end point of
the support line (defined by the set point of the section).
If you want to route the run as a continuation of the extisting element,
select the filled circle (i.e., the support line).
If the new element you route has the same type and parameter
values as the element you selected, these options are added to the
Routing Dialog box:
Continue Routing
Create New Route

4. Select the appropriate Continue option.
5. Click in the drawing to define the routing points.
6. Double-click the last point to stop routing.

Branching a Run
This task explains how to route a run that branches from any of these elements
in a drawing:
Another run
Boundary
Contour
Equipment
Pathway
If the "source" element (i.e., the element from which the run branches) is moved
or resized, the run is adjusted accordingly.
1. Select the Run icon

.

The Routing dialog box is displayed.
2. Define the parameters for the run.
See Creating a Run on an Area for instructions.
3. Select the element from which you want to route the run.
For a contour, select the edge.
For an equipment, select an alignment vector.
For runs that are displayed with a section, base your selection on the
"cues" that are displayed as you move the cursor over the element:
A dashed line is displayed when your cursor is over the
center of a section.
A solid line is displayed when the cursor is over the support
line (defined by the set point of the section).
If you want to create a run that "branches" from the end of a run, see Routing
From the End of a Run.

Modifying Runs
You can modify runs in any of the following ways.

Changing a Section

Disconnecting Runs

Changing the Angle of a Segment

Moving Nodes

Connecting Runs

Changing a Section
This task explains how to change parameters that control how the section of an
element is displayed.
1. Place your cursor over the element and click the right mouse button.
2. From the pull-down menu, select the element you want to modify and select
Definition.
The Run Definition dialog box is displayed.
3. Select the Section option.
The Section dialog box is displayed.
4. Select No Section, Rectangular Section, or Circular Section.
If you select Rectangular Section, you can define or change these
parameters:
Set Point
Height
Width
Display
If you select Circular Section, you can define or change these
parameters:
Set Point
Diameter
5. Click OK on the Section dialog box and OK on the Run Definition box to
complete the change..

Changing the Angle of a Segment
This task shows you how to change the angle of a pathway, boundary, or run
segment.
1. Place your cursor over the element and click the right mouse button.
2. From the pull-down menu, select the element you want to modify and select
Definition.
The Run Definition dialog box is displayed.
3. Place the cursor over the support line for that element and click the right
mouse button.
2. Select Definition from the pop-menu.
The Segment Definition dialog box is displayed.
4. Specify a new value for the Turn Angle.
A line is displayed in the drawing to show the new position for the segment.
5. Select OK on the Segment Definition dialog box.
6. Select OK on the Run Definition dialog box to complete the change.

Moving Nodes
This task shows you how to move the nodes on a pathway, boundary, or run.

1. Place your cursor over the element and click the right mouse button.
2. From the pull-down menu, select the element you want to modify and select
Definition.
The Run Definition dialog box is displayed, and symbols are displayed on the
element to show the location of nodes: Xs represent non-connected nodes, and
Os (circles) represent connected nodes.
3. Do either of the following to move the node:
To move the node by keying in coordinates, do the following:
a. Right-click the node symbol and select Definition from the
pop-menu.
The Node Definition dialog box is displayed.
b. Key in new values for X, Y, or Z.
c. Select OK on the Node Definition dialog box.
To move the node using the cursor, place the cursor over the node
symbol and drag it to a new location.
A line is displayed to show the new location for the segment.
5. Select OK on the Run Definition dialog box to complete the change.

Disconnecting Runs
This task shows you how to disconnect a run from another element.
1. Place your cursor over the run and click the right mouse button.
2. From the pull-down menu, select the element you want to modify and select
Definition.
The Run Definition dialog box is displayed, and an O (circle) node symbol is
displayed on the run where it is connected to the other element.
3. Right-click the node symbol and select Disconnect from the pop-menu.
3. Select OK on the Run Definition dialog box.

Connecting Runs
This task shows you how to connect a pathway, boundary, or run to another
element.
1. Place your cursor over the element and click the right mouse button.
2. From the pull-down menu, select the element you want to modify and select
Connect Routes.
3. Select the element to which you want the first element connected.

Placing Parts
This task shows you how to place a part from a catalog into a CATProduct
drawing.
1. To open a catalog, follow these steps:

. From the menu bar, select the Open icon
or File -> Open.
b. Navigate to the directory in which the catalogs are stored.
c. Click on the name of a catalog name to open it.
A pop-up message tells you that the catalog is read-only file.
d. Click OK on the warning panel.
e. Double-click on the catalog icon to display a list of contents.
2. Resize the catalog and the CATProduct windows so that you can see both of
them at once.
You can select Window -> Tile Vertically to display the windows side by side..
4. Click the CATProduct window to make it active.
5. Make the appropriate element in the drawing active.
6. Place your cursor over the part in the catalog and drag it over the desired
location in the CATProduct window.
The part is displayed in the drawing.

Advanced Tasks
Theme
Advanced Layout Tools

Purpose
Describes how to mirror elements and rearrange
elements in the specification tree.

Advanced Layout Tools
The following procedures describe the tools available in the Systems Routing product
for advanced layout functions.
Mirroring Elements
Rearranging Elements in the
Specification Tree

Mirroring Elements
This task shows you how to move one or more elements to the opposite side of a
selected plane, as a mirror image.
1. Select the element(s) you want to move.
2. Select the Mirror icon
.
3. Define a reference plane across which to mirror the element by doing the
following:
. Place your cursor over a geometric element that defines the plane (e.g., a
construction plane, boundary, area contour, item reservation).
As you move the cursor, a small white rectangle is displayed to show
the selectable planes.

If you do not see the white rectangle, zoom out from the drawing. The
white rectangle cannot be displayed if the element under your cursor
is displayed too small.
b. Click to select the plane.
The selected elements are mirrored to the other side of the plane,.

Rearranging Elements in the
Specification Tree
This task shows you how to transfer elements in your layout from one level of the
specification tree to another.
1. Select the elements you want to transfer.
2. Select the Transfer Nodes icon
.
3. Select the element to which you want the elements transferred.
The elements you select in step 1 become subordinate (children) of the element
you select in step 3.

Customizing
This section describes the ways in which you can customize the Systems Routing
workbench.
Themes
Customizing the Dictionary of Types
Creating a Catalog

Customizing the Dictionary of User
Types
This task explains how to customize the list of types that are displayed when you
create any of these elements:
Distribution systems
Logical Lines
Runs
A basic dictionary of these element types is provided with the product. You can
add entries to or delete entries from the basic dictionary, or you can replace it
entirely. You can also customize the icons that are associated with the element
types.
To customize the dictionary, you need to run the following scripts:
PSLNomenAccessFeat.CATScript reads the existing dictionary and writes it to
a preformatted Microsoft* Excel file.
PSLNomenBuildFeat.CATScript takes a properly fomatted Excel file and
generates a new dictionary.
To accomplish this procedure, you must have installed Microsoft Excel 97 or
later version. You should be familiar with the basic editing features of Excel, as
well as with the file navigation and file editing capabilities of your system.
1. Copy the following files from \intel_a\code\command to a drive or directory
for which you have read and write permissions:
PSLNomenAccessFeat.CATScript
PSLNomenBuildFeat.CATScript
PSLNomenAccessFeatTemplate.xls
2. Start CATIA.
3. From the menu bar, select Tools -> Macro -> Macros.
4. Select Macro In: External File.
5. Select the Select button, and use the Windows dialog box to navigate to the
appropriate file.
6. Select the file PSLNomenAccessFeat.CATScript and select OK.

7. Edit PSLNomenAccessFeat.CATScript as follows:
Define the path strEXCELTemplateFileName to point to the
directory to which you copied the files in step 1.
8. Save and close the file.
9. Select Run.
Microsoft Excel is launched, and a file is created.
10. Edit the Excel file to add or delete entries, as appropriate.
11. Save the Excel file with a unique name.
12. From the CATIA menu bar, select Tools -> Macro -> Macros again.
13. Select the Select button, and select the file
PSLNomenBuildFeat.CATScript.
14. Edit PSLNomenBuildFeat.CATScript as follows:
Define the input path strEXCELInputFileName to point to the Excel file
you saved in step 11.
Define the output path strCATIAV5FeatOutputFileName to point to
\intel_a\resources\graphic\CATArrNomenclature.feat.
If you do not have write permissions for this output path directory, you can define
a temporary location. Contact your system administrator to move or copy the file
to the correct location after it has been created.
15. Save and close the file.
16. Select Run.
The output file is created in the directory you specified. If you defined a
temporary location for the file, it must be moved or copied to
\intel_a\resources\graphicCATArrNomenclature.feat before the modifications
can take effect.
The modifications will take effect when you restart CATIA.

Creating a Catalog
The following three tasks are required for creating a catalog that can be used to place
parts in the Systems Routing product.

Creating Parts

Creating a Catalog

Making a Catalog Accessible

Creating Parts
This task explains how to create parts for the Systems Routing Product.
1. Create the geometry for the part.
Use the CATIA Version 5 Part Design product to create the geometry. See the
CATIA Version 5 Part Design User's Guide for instructions about how to use this
product..
If you want to be able to place the part parametrically, go on to step 2.
For non-parametric parts, save the part as a CATPart document and skip
to step 5.
2. Define parameters for the geometry.
When you define parameters, you must adhere to the following naming
conventions to ensure that the part can be sized correctly when it is placed. The
values for these reserved parameters are derived from the run on which the part
is placed.
CATRouOutsideDiameter -- outside diameter of the part if it is placed on a
cylindrical run
CATRouOutsideHeight -- overall height of the part if it is placed on a
rectangular run
CATRouOutsideWidth -- overall width of the part if it is placed on a
rectangular run
CATRouFaceToFaceLength -- overall length of a stretchable part such as
pipe or duct
CATRouAngle -- turn or branch angle of parts such as an elbow or tee
CATRouTurnRadius -- bend radius of a part such as an elbow or
horizontal turn
All of these parameters do not need to exist on every part. Define only those
parameters that apply to the part you are creating. For example, to create a
straight cylindrical part, you would define only the CATRouOutsideDiameter and
CATRouFaceToFaceLength parameters.
In addition to the reserved parameters, you may define other parameters on the
part. These parameters must also be included in the design table so that the
parameters can be resolved when the part is placed.
3. Save the part as a CATPart document.

4. Create the design tables.
See the CATIA Version 5 Infrastructure User's Guide for detailed instructions on
how to create a design table and associate it to a part.
Design tables are used to manage the allowable combinations of values for the
parameters of a part. You must create tables with the following reserved names
in order for them to be recognized by the Systems Routing product.
CATRouFixedSize
This table must contain the reserved parameters described after step
2, above. These parameters are used as a key to select of the
appropriate row in the table. When the part is placed, the values for
these parameters are derived from the run. In order for the placement
of the part to be successful, the values of the key parameters on the
run must match exactly one of the row entries in the table.
This table must also contain parameters not associated with the run,
if any, that are needed to complete the geometry definition.
CATRouParametricSize
This table is used to define parameters that can be dynamically
defined by the run. All parameters in this table must be defined on the
run. When a part is placed, the values for these parameters are
retrieved from the run and used to size the geometry.

5. Define connectors on the part by following the steps below.
Connectors are used to properly position, align, and orient parts when they are
placed on a run. In addition, they are used to properly position, align, and orient a
run that is started from a part.
. Start a new CATProduct document.
b. RIght-click the Product in the specification tree and select Existing
Component.
c.
d.
e.
f.
g.

The Insert an Existing Component dialog box is displayed.
Find and select the CATPart document you saved.
Click the part in the Specification Tree to make the part active.
Enter the Assembly Design workbench.
On the menu bar, select Tools -> Publication Management... .
Use the Publication Management facility to add connectors.
See the CATIA Version 5 Assembly Design User's Guide for the

specific instructions about using the Publications Management
facility.
h. Save the CATProduct document.
When you define connectors for a part, you must adhere to the
following naming conventions to ensure that the part will be correctly
positioned, aligned, and oriented. When placing a part onto a run or
attaching one part to another, these connectors are used to properly
position, align, and orient the part. When routing a run from the part,
these connectors will be used to locate the start of the run and
ensure proper alignment and orientation of the run.
CATRouFace1, CATRouFace2, ... to define the location for each face of
the part. For placement, these connectors will be used to define the proper
position of the part. If the part is stretchable, these connectors will also be
used to define the extremity positions of the part. For routing from a part,
these connectors will be used to define the start point of the run.
CATRouAlignment1, CATRouAlignment2, ... to define the alignment of
parts and runs that are attached to this part. For placement of a part or
routing from a part, these connectors will define the alignment.
CATRouOrientation1, CATRouOrientation2,.. to define the
orientation/clocking of a part when placed on a run. For placement, these
connectors are used to properly orient/rotate the part to be oriented with
the run.

Creating a Catalog
This task explains how to create a catalog. The Catalog facility is a standard facility provided with the V5 CATIA Product line. For detailed
information regarding Catalogs, please see the CATIA Infrastructure documentation - Advanced Tasks - Using Catalogs.
The following steps outline how to create a catalog of parts. These steps use an existing sample catalog from the Systems Routing product to
illustrate the procedures.
1. Open the file ..\intel_a\startup\components\piping\data\master_piping.xls, shown below:

This file is used to define all information required to create the catalog. It contains the hierarchy of the catalog and all of the associated parts.
For each part, the part name, an associated icon, and associated Part or Product document name is specified. For example, TEE is one of the
parts included in the above example. For this part, the part name is TEE, the icon name is I_catalog_piping_TEE, and the document is
TEE.CATPart.
2. Using the master_piping.xls file as an example, create a catalog hierarchy node for your catalog. For each node, create the part entries for
the parts to be included under this node of the hierarchy.
3. Switch to the Commands sheet within the Excel document. It looks like this:

4. Modify the Output Directory file to point to the appropriate directory.
5. Select the Create Catalog.CSV files button. This will generate the required CSV files for the catalog creation. As this macro runs, you will be
prompted to confirm creation of each CSV file. For each confirmation request, hit OK.
6. Use the File-SaveAs to save this as a new document.
7. Before being able to proceed to the next step, you must make sure the CclTypeLib library is loaded. This library declares the catalog creation
method. To do this, select the Tools->Options... command. The Options dialog box appears with the General category selected in the left-hand
column.
8. Click the !Automation! tab. The following dialog box appears:

9. If the CclTypeLib library is not in the Selected list click on the Add button and retrieve the library from intel_a/code/bin. Make sure it is in the
Selected list before clicking OK.
10. You are now ready to run the batch operation. Select the Tools ->Macro->Macros command. The following dialog box appears:

11. Select the BuildCatalogVB.CATScript file. Make sure that at the bottom of the box External File is selected indicating the location of the
macro. Click on Run.
12. A window will be displayed that prompts you for the input path. This input path defines where the macro will find the CSV files. For the
input path, specific the directory you defined in step 4 above.
13. A window will be displayed that prompts you for the output path. This is used to specify where the directory where the catalog will be filed.
This process will also generate a report file in this directory. This directory will allow you to verify the successful creation of the catalog.

Making a Catalog Accessible
This task explains how to specify the location of a catalog so that it can be accessed from the Systems
Routing product in order to place parts.
1. From the menu bar, select Tools -> Search Order.
The Search Order dialog box is displayed.
2. Specify a search order that points to the directory in which the catalog is located.
For specific instructions about how to specify a search order, see the CATIA Version 5 Infrastructure User's
Guide (Workbench Description -> Menu Bar -> Tools -> Creating a Document Search Order).

Workbench Description
The CATIA Systems Routing workbench includes the following tool bars:

Systems Routing Tool Bar

General Design Tool Bar

General Environment Tool Bar

Systems Routing Tool Bar
The Systems Routing Tool Bar contains the following tools:

See Creating a Distribution System.

See Creating a Logical Line.
See Routing Runs and Modifying Runs.

General Design Tool Bar
The General Design Tool Bar contains the following tools:

See Mirroring Elements.
See Flipping Elements.
See Rearranging Elements in the Specification Tree.
Update the Display.

General Environment Tool Bar
The General Environment Tool Bar contains the following tools:

See Changing the Current Axis.

See Using Offset Planes.
See Using a Step Grid for these icons:

Snap to steps off current axis
Snap to steps off last position
Snap to XY construction plane
Snap to all construction planes
Snap to elevation (Z) construction plane
Snap to Drafting elements
See Making an Element Active.
See Making an Element Active for these icons:

Activate Parent
Activate Area

Glossary
B
body

See part body.

C
chamfer

A cut through the thickness of the feature at an angle, giving a sloping
edge.
child
A status defining the genealogical relationship between a feature or
element and another feature or element. For instance, a pad is the child of
a sketch. See also parent.
constraint A geometric or dimension relation between two elements.

D
draft angle A feature provided with a face with an angle and a pulling direction.

F
feature
fillet

A component of a part. For instance, shafts, fillets and drafts are features.
A curved surface of a constant or variable radius that is tangent to, and
that joins
two surfaces. Together, these three surfaces form either an inside corner
or an
outside corner.

G
groove

A feature corresponding to a cut in the shape of a revolved feature.

H
hole

A feature corresponding to an opening through a feature. Holes can be
simple, tapered, counterbored, countersunk, or counterdrilled.

M
mirror

A feature created by duplicating an initial feature. The duplication is
defined by symmetry.

P
pad
parent

A feature created by extruding a profile.
A status defining the genealogical relationship between a feature or
element and another feature or element. For instance, a pad is the parent
of a draft.
part
A 3D entity obtained by combining different features.
part body A component of a part made of one or several features.
pattern
A set of similar features repeated in the same feature or part.
pocket
A feature corresponding to an opening through a feature. The shape of the
opening corresponds to the extrusion of a profile.
profile
An open or closed shape including arcs and lines created by the profile
command in the Sketcher workbench.

R
reorder
rib

An operation consisting in reorganizing the order of creation of the
features.
A feature obtained by sweeping a profile along a center curve.

S
scaling
shaft
shell
sketch
slot
split
stiffener

An operation that resizes features to a percentage of their initial sizes.
A revolved feature
A hollowed out feature
A set of geometric elements created in the Sketcher workbench. For
instance, a sketch may include a profile, construction lines and points.
A feature consisting of a passage through a part obtained by sweeping a
profile along a center curve.
A feature created by cutting a part or feature into another part or feature
using a plane or face.
A feature used for reinforcing a feature or part.

Index
A
activating an element
axis
changing the current axis

C
catalog
accessing
creating
connecting runs
current axis
changing

D
dictionary of types
customizing
disconnecting runs
distribution system
creating
customizing the list of types for

E
elements
flipping
making active
mirroring
rearranging in the hierarchy tree
snapping to a grid

F
flipping elements

G
grid
using

H
hierarchy tree
rearranging elements in

L
logical line
creating
customizing the list of types for

M
mirroring elements

N
nodes
moving

P
parts
creating
placing

R
runs
branching
connecting
customizing the list of types for
disconnecting
modifying
routing from the end of a path reservation, boundary, or run
routing orthogonally
routing point to point

S
section setting for runs
changing
segments of a run
changing the angle of
step grid
using

T
types
customizing the dictionary of

